MSIDEPLOYMENTCOMPLIANT-Eigenschaft

Die MSIDEPLOYMENTCOMPLIANT-Eigenschaft kann so festgelegt werden, dass das Installationsprogramm angegeben wird, dass das Paket erstellt und getestet wurde, um die Benutzerkontensteuerung (User Account Control, UAC) in Windows Vista einzuhalten. Wenn diese Eigenschaft nicht festgelegt ist, bestimmt das Installationsprogramm, ob das Paket UAC auf Windows Vista erfüllt.

Weitere Informationen zu UAC und Windows Installer finden Sie unter Verwenden des Windows Installers mit UAC und Richtlinien für Pakete.

Windows Installer 3.1, Windows Installer 3.0 und Windows Installer 2.0: Diese Eigenschaft wird ignoriert. Diese Eigenschaft wird nur von Windows Installer 4.0 in Windows Vista verwendet.

Requirements (Anforderungen)

Anforderung Wert
Version
Windows Installer 5.0 auf Windows Server 2012, Windows 8, Windows Server 2008 R2 oder Windows 7. Windows Installer 4.0 oder Windows Installer 4.5 auf Windows Server 2008 oder Windows Vista. Weitere Informationen zum Mindest service Pack, das von einer Windows Installer-Version benötigt wird, finden Sie im Windows Installer Run-Time Anforderungen.

Siehe auch

Eigenschaften

In Windows Installer 3.1 und früheren Versionen nicht unterstützt