Azure container instance continues to run after the stop or delete command
This article provides a solution to an issue where an Azure container instance continues to run even after the stop
or delete
command has been executed.
Symptoms
Despite executing the stop
or delete
command, an Azure container instance continues to run and is still billed.
Cause
This issue might occur due to potential bugs in the container stop or delete process.
Solution
To resolve this issue, follow these steps:
- Verify that the
stop
ordelete
command was executed. - Verify that the container instance is still billed.
- Create a new container instance with the same resource ID in the same region. Upon successful creation, the old container instance will be deleted immediately.
Contact us for help
If you have questions or need help, create a support request, or ask Azure community support. You can also submit product feedback to Azure feedback community.