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"AccountEncryptionKeyUnavailable" error when you try to list pools in Azure Batch

This article explains how to handle an "AccountEncryptionKeyUnavailable" error message in Azure Batch. This error might occur when you try to view a list of pools.

Symptoms

When you select Pools in the upper-left corner of the Azure portal under Features, you can't see the list of Azure Batch pools. Instead, you receive the following error message:

AccountEncryptionKeyUnavailable message: Account data could not be decrypted as the account encryption key is currently unavailable.

The reason code is AccountKeysNotFound.

Cause

This is a known issue in Azure Batch. This issue occurs if your subscription was suspended. There are various reasons why a subscription might be suspended, such as fraud and running out of credits.

Solution

The product team is working on a solution for this issue. We intend to deploy a fix soon. Currently, the only way to mitigate the issue is to delete and re-create the batch account.

To handle a suspended subscription, see Reactivate a disabled Azure subscription.

Contact us for help

If you have questions or need help, create a support request, or ask Azure community support. You can also submit product feedback to Azure feedback community.