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An activity times out in Business Central cloud migration

This article provides troubleshooting steps for an issue where an activity times out during Business Central cloud migration.

Symptoms

An activity times out during Business Central cloud migration.

Cause

If an activity times out during the cloud migration setup, it might happen either because Integration Runtime couldn't establish a connection to SQL Server or because of index defragmentation in large on-premises databases. If it times out during a migration run, the reason is most likely a weak or busy on-premises SQL Server.

Resolution

  • If the SQL connection is permanently broken, check if .NET 4.72, or higher is running on the host of the integration runtime.

  • Check other Integration Runtime requirements on the Azure Data Factory page.

  • For the database performance problems, we recommend updating statistics and reorganizing indexes in the on-premises database before setting up cloud migration.

    • To update statistics, run the following query (for example, in Microsoft SQL Management Studio connected to the on-premises database):

      EXEC sp_updatestats;
      
    • To reorganize indexes, execute the following query:

      EXEC sys.sp_MSforeachtable 'ALTER INDEX ALL ON ? REORGANIZE'
      

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