Email configuration manager was not able to read configuration information Error occurs when you launch the Microsoft Dynamics CRM Email Router Configuration Manager

This article provides a solution to an error that occurs when you launch the Microsoft Dynamics CRM Email Router Configuration Manager.

Applies to:   Microsoft Dynamics CRM
Original KB number:   2012555

Symptoms

When you launch the Microsoft Dynamics CRM Email Router Configuration Manager, you receive the following error:

"Email configuration manager was not able to read configuration information."

Cause

The Microsoft.Crm.Tools.EmailAgent.Configuration.bin located at C:\Program Files\Microsoft CRM Email\Service is corrupted or is 0 KB in size.

Resolution

Use one of the following resolutions to resolve this error.

Resolution 1

Repair or reinstall the Microsoft Dynamics CRM Email Router.

Resolution 2

  1. Delete the Microsoft.Crm.Tools.EmailAgent.Configuration.bin located at C:\Program Files\Microsoft CRM Email\Service.
  2. Restart the Microsoft Dynamics CRM Email Router service.
  3. Now launch the Email Router Configuration Manager. A new Microsoft.Crm.Tools.EmailAgent.Configuration.bin will be created, and a blank configuration will appear.
  4. Configure all the profiles and the deployments.

If Microsoft Dynamics CRM users are set to use the Email Router, and not a Forward Mailbox, for incoming email, there's a possibility of deleted emails returning to Microsoft Dynamics CRM after implementing this resolution. If an email hasn't been deleted from the user's mailbox, the Email Router could find a user's email in their Inbox, not find it in Microsoft Dynamics CRM, and create the email in Microsoft Dynamics CRM again. To avoid it, the email should also be deleted from the user's mailbox along with Microsoft Dynamics CRM.

To avoid this situation, regularly take a backup of the following files and store them on the desktop of the same server.

  • Microsoft.Crm.Tools.EmailAgent.Configuration.bin

  • Microsoft.Crm.Tools.EmailAgent.SystemState.Xml

If the Microsoft Dynamics CRM Email Router Configuration Manager fails at launch or the Microsoft Dynamics CRM Email Router service fails to start, replace the above two files in C:\Program Files\Microsoft CRM Email\Service. Restart the Microsoft Dynamics CRM Email Router service and then launch the Microsoft Dynamics CRM Email Router Configuration Manager. If the backup of these files is latest, then it will have the complete configuration of the Email Router.

More information

Check if you're able to open launch the Email router configuration manager by running the exe Microsoft.Crm.Tools.Email.Management.exe located at C:\Program Files\Microsoft CRM Email\Service. The size of this exe file should be around 954 KB.

Insight on what happens while you launch the email router configuration manager
The entire configuration of the Email router manager that has the below information is stored in a configuration.bin file that is located at C:\Program Files\Microsoft CRM Email\Service and the name of the config file is - Microsoft.Crm.Tools.EmailAgent.Configuration.bin

Below is the information that is stored in the .bin file.

Incoming Profile details:

  • Type of E-mail Server Type selected.
  • Authentication type selected.
  • The Server URL mentioned in the Location field.
  • The Access Credentials that are used.

Outgoing Profile Details:

  • Type of E-mail Server Type selected.
  • Authentication type selected.
  • The Server URL mentioned in the Location field.
  • The Access Credentials that are used.

Deployment Details:

  • Type of Deployment selected (My Company/An Online Service Provider)
  • The Microsoft Dynamics CRM server URL.
  • Access Credentials used
  • Default Configuration Profiles (Incoming/Outgoing)

User's information:

  • List of users that use the Email router for sending and receiving emails within CRM.

Forward mailbox information if any.