An error occurs when trying to Load Data in Microsoft Dynamics CRM E-mail Router

This article provides a resolution for the issue that you can't load data in Microsoft Dynamics CRM E-mail Router due to error The Email Router Configuration Manager was unable to retrieve user and queue information from the Microsoft Dynamics CRM server.

Applies to:   Microsoft Dynamics CRM
Original KB number:   2755658

Symptoms

When selecting Load Data, the error message below may occur:

The Email Router Configuration Manager was unable to retrieve user and queue information from the Microsoft Dynamics CRM server. This may indicate that the Microsoft Dynamics CRM server is busy. Verify that URL 'https://disco.crm.dynamics.com/OrganizationUniqueName' is correct. Additionally, this problem can occur if specified access credentials are insufficient. To try again, click Load Data. (LogonIdentityExWithUI()).

Additionally, the following error is part of the E-mail Router Tracing:

01/01/2012 12:00:00 : #6188 - The E-mail Router service cannot connect to the Microsoft Dynamics CRM server or the Microsoft Dynamics CRM Online server to access user and queue information. Verify that the account that is used to run the E-mail Router service has sufficient permission to access the Microsoft Dynamics CRM server and that there are no connectivity problems. Microsoft.Crm.Passport.IdCrl.IdCrlException: IntializationFailure

Cause

The latest Microsoft Dynamics CRM E-mail Router Update Rollup and Microsoft Online Services Sign-In Assistant for IT Professionals RTW are not installed on the Microsoft Dynamics CRM E-mail Router server.

Resolution

In order to resolve this problem, install the latest Microsoft Dynamics CRM E-mail Router update rollup along with the Microsoft Online Services Sign-In Assistant for IT Professionals RTW on the Microsoft Dynamics CRM E-mail Router server.

More information

The stack trace may display the following:

Server stack trace:
at Microsoft.Crm.ServiceProxyCache`1.BuildServiceProxy(Uri serviceUrl, Credential credentials, Uri homeRealmUrl, String passportEnvironment, String onlineServiceEnvironment, IServiceConfiguration`1 serviceConfiguration)
at Microsoft.Crm.ServiceProxyCache`1.GetNewServiceProxy(Uri serviceUrl, Credential credentials, Uri homeRealmUrl, String passportEnvironment, String onlineServiceEnvironment)
at Microsoft.Crm.Tools.Email.Providers.OrganizationUrlCache.DiscoverOrganizationUrl(Uri discoveryServiceUrl, Credential credentials, String organizationName)
at System.Lazy`1.CreateValue()

In order to enable the E-mail Router Tracing, follow the article below:

How to enable tracing in Microsoft Dynamics CRM