Share via


Contact card displays phone number instead of name in Skype for Business 2016

Symptoms

In Skype for Business 2016, you may find that a user's contact card shows the phone number instead of the contact's display name.

Cause

This issue occurs when Exchange contact sync is disabled.

To disable Exchange contact sync, run the following command for a specific user or tenant:

Set-CsClientPolicy -EnableExchangeContactSync $false

Resolution

Important

This resolution applies to Office Click-to-Run version 16.0.8431.2079 or later.

Warning

Serious problems might occur if you modify the registry incorrectly by using Registry Editor or by using another method. These problems might require that you reinstall your operating system. Microsoft cannot guarantee that these problems can be solved. Modify the registry at your own risk.

To resolve this problem, apply one of the following settings.

In-band provisioning setting

Run the following command from a Lync PowerShell command prompt:

$a = New-CsClientPolicyEntry -NameEnableContactResolutionWithTelUriAndEmailOnly -Value "true"
 Set-CsClientPolicy-Identity** **Global -PolicyEntry @{Add=$a}

GPO setting

  1. In Group Policy Management, create a Group Policy object.

    Note When you create a GPO, specify a name and leave the source as none.

  2. On the Settings tab, right-click Computer Configuration or User Configuration, and then select Edit.

  3. Right-click Registry, select New, and then select Registry Item.

  4. In the New Registry Properties dialog box, specify the following information, and then select OK:

    Action: Create
    Hive: HKEY_CURRENT_USER
    Key path: Software\Policies\Microsoft\Office\16.0\Lync
    Value name: EnableContactResolutionWithTelUriAndEmailOnly
    Value type: REG_DWORD
    Value data: 1
    Base: Decimal    
    

More information

Still need help? Go to Microsoft Community.