Some Android devices do not redirect to Exchange Online
Original KB number: 3035227
Symptoms
Some Android devices stop receiving new messages after the user's mailbox is moved to Exchange Online.
Cause
This occurs if the Android device doesn't support the MobileSyncRedirectBypass feature.
Beginning with Exchange Server 2010 SP3 RU9, Exchange Server 2013 CU8, and Exchange Server 2016, a new MobileSyncRedirectBypass feature was introduced in the Autodiscover service for Android devices.
By default, this feature is enabled for devices that have the following prefixes:
Acer,ADR9,Ally,Amazon,Android,ASUS,EasClient,FUJITSU,HTC,HUAWEI,LG,LS,Moto,Mozilla,NEC,Nokia,Palm,PANASONIC,PANTECH,Remoba,Samsung,SEMC,SHARP,SONY-,TOSHIBA,Vortex,VS,ZTE
The most recent list of known Android devices that understand this feature can be found in the MobileSyncRedirectBypassClientPrefixes setting in the Autodiscover web.config file. This file is located in the %ExchangeInstallPath%\ClientAccess\Autodiscover folder.
Note
The MobileSyncRedirectBypass feature is generally known as 451 redirect. For more information, see 3.1.5.2.2 HTTP Error 451.
Workaround
If the device isn't in the MobileSyncRedirectBypassClientPrefixes setting in the Autodiscover web.config file, do one of the following:
- Manually edit the server value for the Exchange ActiveSync (EAS) profile after the mailbox is moved to Microsoft 365.
- Test to determine whether the device supports the MobileSyncRedirectBypass feature. If the device supports the feature, edit the MobileSyncRedirectBypassClientPrefixes setting across all Exchange servers in the environment.
For more information, see Exchange ActiveSync on-boarding to Microsoft 365.
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