Action Microsoft.crm.setup.common.analyzer+collectaction failed error occurs during installation of the Email Router in Microsoft Dynamics CRM 2011

This article provides a solution to an error that occurs during installation of the Email Router in Microsoft Dynamics CRM 2011.

Applies to:   Microsoft Dynamics CRM 2011
Original KB number:   2607018

Symptoms

An error occurs during installation of the Email Router in Microsoft Dynamics CRM 2011:

"Action Microsoft.crm.setup.common.analyzer+collectaction failed. Fatal error during installation" Fatal error during installation"

Cause

The problem occurs because of the left over registry keys from the installation of the Microsoft Dynamics CRM 4.0 Email Router.

Resolution

Important

This section, method, or task contains steps that tells you to modify the registry. However, serious problems might occur if you modify the registry incorrectly. So make sure that you follow these steps carefully. For added protection, back up the registry before you modify it. Then, you can restore the registry if a problem occurs. For more information about how to back up and restore the registry, see How to back up and restore the registry in Windows.

Follow below steps to remove the left over registry keys from the Microsoft Dynamics CRM 4.0 Email Router:

  1. Point to the Start menu, and select Run, type regedit, and then select OK.

  2. Make a backup of the registry by pointing to File, and select Export. Ensure that All is selected under Export Range. Enter a name and select Save.

  3. Locate the following folders in the registry:

    • HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\Currentversion\Installer\Folders
    • HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\Installer\UserData\S-1-5-18\Components\AA525E7FC7F524344B2B2650A4C6D64D
  4. Delete any strings in these folders that begin with C:\Program Files\Microsoft CRM Email.

  5. Locate and delete this folder:

    • HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\Installer\UserData\S-1-5-18\Components\68944CFD44299A6449C12100DDA86EE8
  6. Reboot the machine

  7. Install the Microsoft Dynamics CRM 2011 Email Router.