The default printer is incorrect in Microsoft Dynamics SL

This article provides a solution to an issue where the default printer is incorrect in Microsoft Dynamics SL.

Applies to:   Microsoft Dynamics SL
Original KB number:   2018973

Symptoms

The default printer is incorrect in Microsoft Dynamics SL when the following conditions are true:

  • Microsoft Dynamics SL is installed on a server that is running Citrix XenApp or Citrix Presentation Server
  • Microsoft Dynamics SL is configured as a published application

Cause

The problem occurs because the Start this application without waiting for printers to be created option is enabled on Citrix XenApp or on Citrix Presentation Server.

Resolution

Disable the Start this application without waiting for printers to be created option. For more information about how to disable this option, see the Citrix XenApp or Citrix product documentation.

More information

When you start Microsoft Dynamics SL,it automatically searches for the Windows default printer or the printer defined as the default printer in Microsoft Dynamics SL. If the Windows default printer or the printer that is defined as the default printer in Microsoft Dynamics SL hasn't been created when MicrosoftDynamics SLis started as a published application, the incorrect printer is then set as the default printer in Microsoft Dynamics SL.