"Dynamics SQL Database has not been setup for this version" error when you start Microsoft Dynamics GP
This article provides resolutions to solve the Dynamics SQL Database has not been setup for this version error message that may occur when you start Microsoft Dynamics GP.
Applies to: Microsoft Dynamics GP
Original KB number: 850662
Symptoms
When you start Microsoft Dynamics GP or Microsoft Business Solutions - Great Plains, you may receive the following error message:
Dynamics SQL Database has not been setup for this version.
Cause 1
This problem occurs because the values in the tables in the DYNAMICS database do not correspond to the version of Microsoft Dynamics GP or of Microsoft Business Solutions - Great Plains that you are using. See resolution 1.
Cause 2
This problem occurs because the Client installation of Microsoft Dynamics GP was installed instead of the Server installation. You must install the Server installation before you can update the databases in Utilities. See resolution 2.
Cause 3
This problem occurs because the ODBC connection that was selected at the login screen does not point to the instance of Microsoft SQL Server where the Microsoft Dynamics GP databases are located. See resolution 3.
Resolution 1
Make sure that you have a good backup of the DYNAMICS database.
Use Query Analyzer or SQL Management Studio to run the following script against the DYNAMICS database.
SELECT * FROM DYNAMICS..DU000020 SELECT * FROM DYNAMICS..DB_Upgrade
Notes
In the results for the DU000020 table, verify that the values in the following columns correspond to the version of Microsoft Dynamics GP or of Microsoft Great Plains that you are using:
- The versionMajor column
- The versionMinor column
For example, if you are using Microsoft Dynamics GP 9.0, you should see the following values:
- The versionMajor column: 9
- The versionMinor column: 0
In the DB_Upgrade table results, verify that the values in the following columns correspond to the version of Microsoft Dynamics GP or of Microsoft Great Plains that you are using:
- The db_verMajor column
- The db_verMinor column
- The db_verOldMajor column
- The db_verOldMinor column
For example, if you are using Microsoft Dynamics GP 9.0, you should see the following values:
- The db_verMajor column: 9
- The db_verMinor column: 0
- The db_verOldMajor column: 9
- The db_verOldMinor column: 0
If the values in the columns that are listed in step 2 do not correspond to the version of Microsoft Dynamics GP that you are using, run the following scripts in Query Analyzer or in SQL Server Management Studio.
Script 1
update DYNAMICS..DU000020
set versionMajor = VERSIONMAJOR, versionMinor = VERSIONMINOR
where companyID = COMPANYID
Note
- Replace the
VERSIONMAJOR
placeholder and theVERSIONMINOR
placeholder with the numbers of the version that you are currently using. For example, if you are using Microsoft Dynamics GP 9.0, theVERSIONMAJOR
placeholder should be 9 and theVERSIONMINOR
placeholder should be 0. - Replace the
COMPANYID
placeholder with the company ID of the company that has the incorrect version information. To determine the company ID, run the following statement:
SELECT * FROM DYNAMICS..SY01500
Script 2
update DYNAMICS..DB_Upgrade
set db_verMajor = VERSIONMAJOR, db_verMinor = VERSIONMINOR
where db_name = DATABASENAME
Note
- Replace the
VERSIONMAJOR
placeholder and theVERSIONMINOR
placeholder with the numbers of the version that you are currently using. For example, if you are using Microsoft Dynamics GP 9.0, theVERSIONMAJOR
placeholder should be 9 and theVERSIONMINOR
placeholder should be 0. - Replace the
DATABASENAME
placeholder with the name of the database for the company.
Resolution 2
Microsoft Dynamics GP
If you are using Microsoft Dynamics GP, remove the Client installation and reinstall the Server installation. To do this, follow these steps:
- Select Start, select Control Panel, and then select Add or Remove Programs.
- On the list, select Microsoft Dynamics GP, and then select Change.
- Select Remove to remove the Client installation of Microsoft Dynamics GP.
- When you reinstall Microsoft Dynamics GP, select Server in the Installation Type window, and then select Next.
- Finish the installation.
Microsoft Business Solutions - Great Plains
If you are using Microsoft Business Solutions - Great Plains, convert the Client installation to a Server installation. To do this, follow these steps:
- Start the installation by using CD 1 of the Microsoft Business Solutions - Great Plains installation CD set. To do this, double-click the CDSetup.exe file.
- Select Install Great Plains, and then accept the same default settings that you used for the Client installation except for the following settings:
- At the Select to Install Server or Client window, select Server and Client Installation.
- At the Select Great Plains Components window, select SQL Server Objects.
- Finish the installation.
Resolution 3
At the login screen, select the correct ODBC connection in the Server drop-down list. Follow the steps in the following article to verify that the ODBC connection has been set up correctly and that the connection references the correct instance of SQL Server that contains your Microsoft Dynamics GP databases:
How to set up an ODBC Data Source on SQL Server for Microsoft Dynamics GP