Unable to see any performance or availability details using System Center 2012 Operations Manager widgets
This article helps you fix an issue in which you are unable to see any performance or availability details when you use performance widgets in System Center 2012 Operations Manager.
Original product version: System Center 2012 Operations Manager
Original KB number: 2711375
Symptoms
When using performance widgets in System Center 2012 Operations Manager, you may experience one or more of the following symptoms:
While creating performance widgets, none of the performance objects or counters are shown in the wizard.
You're unable to retrieve availability details using Operations Manager state widgets.
Network dashboard views aren't showing any availability details or performance details.
The Reset Health State task fails with the exception below shown under the task status view:
A module reported an error 0x80070490 from a callback which was running as part of rule "System.Health.ResetState" running for instance "<instance name>" with id:"{GUID}" in management group "<Management Group Name>".
Error Code: -2130771918 (Unknown error (0x80ff0032)).
Cause
It can occur if the management group ID is different in the MT_ManagementGroup
and __MOMManagementGroupInfo__
tables. If you create the OperationsManager
database using DBCreateWizard.exe, the management group GUIDs will be different. We can safely change the management group ID in __MOMManagementGroupInfo__
table.
Note
This issue will only happen on upgraded environments from System Center Operations Manager 2007 R2.
Resolution
To resolve this issue, complete the steps below.
Find the management group ID in
MT_ManagementGroup
and__MOMManagementGroupInfo__
tables. To do it, run the following queries on theOperationsManager
database:Select ManagementGroupId from __MOMManagementGroupInfo__ Select Id_6B1D1BE8_EBB4_B425_08DC_2385C5930B04 from MT_ManagementGroup
If the values (GUIDs) are different, change the management group ID in the
__MOMManagementGroupInfo__
table. To do it, run the following query to update the__MOMManagementGroupInfo__
table:Update __MOMManagementGroupInfo__ SET ManagementGroupId = '<GUID>'
Note
Change the <GUID> to match the ID from
MT_ManagementGroup
table.Once the query is executed, restart the System Center Data Access Service, the System Center Management Configuration service, and the System Center Management service on the management server.
Reopen the Operations Manager console using the
/clearcache
switch. For example, run the following command at a command prompt:microsoft.mom.ui.console.exe /clearcache
More information
Make sure that you have recent backups of the OperationsManager
and OperationsManagerDW
databases before updating the tables.