@Mike Chace , Based on my research, 0x87d1fde8 (The system cannot find the file specified.) can be caused that the OMA-URI used in the above-mentioned policy is not correct. Please contact Lenovo support to find out the correct OMA-URI and the format of the value. Here is a similar link with the same error for the reference:
https://howtomanagedevices.com/intune/2475/fix-error-code-0x87d1fde8-remediation-failed/
Note:: Non-Microsoft link, just for the reference.
After looking into the issue, the solution is found as below:
Cause:
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The ADMX Ingest had not completed on the test machine prior to the configuration CSP being run. So, there weren't any settings loaded into the registry to Add/Chang
Resolution:
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Check the status of the Ingest CSP prior to the Configuration CSP. It is working after the ADMX Ingest is completed.
Hope it can help.
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