CSP fails with error 0x87d1fde8 configuring Lenovo Commercial Vantage

Mike Chace 21 Reputation points
2021-02-10T22:13:51.197+00:00

I created a new CSP in Intune to configure policy for Lenovo Commercial Vantage. This CSP is configured to modify 7 settings within the Commercial Vantage app. I receive an error in Intune from each of the 7 settings. Below is a copy of one of the errors from Intune.

66701-image.png

Setting error
SETTING
11116BCCD9E515307397B1CE23E74D13 [./Device/Vendor/MSFT/Policy/Config/CommercialVantage~Policy~03E445D7B5956335BEDEF9340AC7E092~247D6178BE8CC3C83409E26C3E1CE0D9/11116BCCD9E515307397B1CE23E74D13]
STATE
Error
SOURCE PROFILES
Source Profile
Corp Win10 - Custom - Commercial Vantage Config
ERROR CODE
0x87d1fde8
ERROR DETAILS
Remediation failed

This is the error as shown in the event viewer.

MDM ConfigurationManager: Command failure status. Configuration Source ID: (6D330AA8-354C-493B-AB31-730F86D628AB), Enrollment Name: (MDMDeviceWithAAD), Provider Name: (Policy), Command Type: (Add: from Replace or Add), CSP URI: (./Device/Vendor/MSFT/Policy/Config/CommercialVantage~Policy~03E445D7B5956335BEDEF9340AC7E092~247D6178BE8CC3C83409E26C3E1CE0D9/11116BCCD9E515307397B1CE23E74D13), Result: (The system cannot find the file specified.).

Microsoft Security | Intune | Configuration
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Accepted answer
  1. Crystal-MSFT 53,991 Reputation points Microsoft External Staff
    2021-02-11T04:49:44.603+00:00

    @Mike Chace , Based on my research, 0x87d1fde8 (The system cannot find the file specified.) can be caused that the OMA-URI used in the above-mentioned policy is not correct. Please contact Lenovo support to find out the correct OMA-URI and the format of the value. Here is a similar link with the same error for the reference:
    https://howtomanagedevices.com/intune/2475/fix-error-code-0x87d1fde8-remediation-failed/
    Note:: Non-Microsoft link, just for the reference.

    After looking into the issue, the solution is found as below:

    Cause:

    =============

    The ADMX Ingest had not completed on the test machine prior to the configuration CSP being run. So, there weren't any settings loaded into the registry to Add/Chang

    Resolution:

    =============

    Check the status of the Ingest CSP prior to the Configuration CSP. It is working after the ADMX Ingest is completed.

    Hope it can help.


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