Edit

Use Visual Studio to create databases for SQL Server on Linux

Applies to: SQL Server on Linux

SQL Server Data Tools (SSDT) turns Visual Studio into a powerful development and database lifecycle management (DLM) environment for SQL Server on Linux. You can develop, build, test, and publish your database from a source-controlled project, just as you develop your application code.

Install Visual Studio and SQL Server Data Tools

  1. If you haven't already installed Visual Studio on your Windows machine, Download and Install Visual Studio. If you don't have a Visual Studio license, Visual Studio Community edition is a free, fully featured IDE for students, open-source, and individual developers.

  2. During the Visual Studio installation, select Custom for the Choose the type of installation option. Select Next.

  3. Select Microsoft SQL Server Data Tools, Git for Windows, and GitHub Extension for Visual Studio from the feature selection list.

    Screenshot of SSDT setup.

  4. Continue and finish the installation of Visual Studio. It can take a few minutes.

Get the latest version of SQL Server Data Tools

SQL Server on Linux is supported by SSDT version 17.0 or later.

Create a new database project in source control

  1. Launch Visual Studio.

  2. Select Team Explorer on the View menu.

  3. Select New in the Local Git Repository section on the Connect page.

    Screenshot of the Local Git Repository section with the New option called out.

  4. Select Create. After the local Git repository is created, double-click SSDTRepo.

  5. Select New in the Solutions section. Select SQL Server under the Other Languages node in the New Project dialog.

    Screenshot of the Solutions section with the New option and SQL Server option called out.

  6. Enter TutorialDB as the name, and then select OK to create a new database project.

Create a new table in the database project

  1. Select Solution Explorer on the View menu.

  2. Open the database project menu by right-clicking on TutorialDB in Solution Explorer.

  3. Select Table under Add.

    Screenshot showing how to create a new table using Add > Table.

  4. In the table designer, add the Name and Location columns. Set both columns to the nvarchar(50) data type, as shown in the image. SSDT generates the CREATE TABLE script as you add the columns in the designer.

    Screenshot of the table designer with the Name and Location values called out.

  5. Save the Table1.sql file.

Build and validate the database

  1. Open the database project menu on TutorialDB and select Build. SSDT compiles the .sql source files in your project and builds a data-tier application package (DACPAC) file. You can use this file to publish a database to your SQL Server instance on Linux.

    Screenshot showing the TutorialDB with the Build option called out.

  2. Check for a build success message in the Output window in Visual Studio.

Publish the database to a SQL Server instance on Linux

  1. Open the database project menu on TutorialDB and select Publish.

  2. Select Edit to select your SQL Server instance on Linux.

    Screenshot showing the Publish option with the Edit option called out.

  3. In the connection dialog, enter the IP address or host name, user name, and password for your SQL Server instance on Linux.

    Screenshot showing the connection dialog.

  4. Select Publish in the publish dialog.

  5. Check the publish status in the Data Tools Operations window.

  6. Select View Results or View Script to see details of the database publish result on your SQL Server on Linux.

    Screenshot showing the publish result with View Script and View Results called out.

You've successfully created a new database on a SQL Server instance on Linux and learned the basics of developing a database with a source-controlled database project.