First Salesforce CRM user can't access Copilot for Sales
This article helps you troubleshoot and resolve an error message that occurs in Microsoft Copilot for Sales related to signing in to Salesforce.
Note
Microsoft Sales Copilot is rebranded as Microsoft Copilot for Sales in January 2024. The screenshots in this article will be updated with the new name soon.
Who is affected?
Requirement type | Description |
---|---|
Client app | Copilot for Sales Outlook add-in |
Platform | Web and desktop clients |
OS | Windows and Mac |
Deployment | User managed and admin managed |
CRM | Salesforce |
Users | The first user who tries to sign in to Salesforce CRM from Copilot for Sales. |
Symptoms
When the first user in an organization tries to sign in to Salesforce CRM from Copilot for Sales, a trial environment needs to be created. When the user doesn't have permission to create a trial environment, the following error message is displayed:
Updated setting required
To use this app, ask your Power Platform admin to let you use Copilot for Sales, and include the error details in your request.
Cause
Tenant's administrators have disabled trial environment creation for non-administrator users.
Resolution
As a tenant administrator, follow these steps to allow users to create trial environments:
Sign in to the Power Platform admin center with your administrator credentials.
In the left navigation pane, select Settings.
On the Tenant settings page, select Trial environment assignments.
In the Trial environment assignments panel, select Everyone.
Select Save.
More information
If your issue is still unresolved, go to the Copilot for Sales - Microsoft Community Hub to engage with our experts.
Third-party information disclaimer
The third-party products that this article discusses are manufactured by companies that are independent of Microsoft. Microsoft makes no warranty, implied or otherwise, about the performance or reliability of these products.