Error with Columnar Index

Wajih Arfaoui 70 Reputation points
2024-02-28T10:30:58.3933333+00:00

Hello, I am creating a pipeline with a Copy activity to get a table from SQL databse to Synapse and I am getting this error : Column '' has a data type that cannot participate in a columnstore index. How can I fix this in ADF ? Thank you

Azure Synapse Analytics
Azure Synapse Analytics
An Azure analytics service that brings together data integration, enterprise data warehousing, and big data analytics. Previously known as Azure SQL Data Warehouse.
4,350 questions
Azure Data Factory
Azure Data Factory
An Azure service for ingesting, preparing, and transforming data at scale.
9,498 questions
0 comments No comments
{count} vote

1 answer

Sort by: Most helpful
  1. Vinodh247-1375 11,036 Reputation points
    2024-02-28T11:07:34.5733333+00:00

    Hi Wajih Arfaoui,

    Thanks for reaching out to Microsoft Q&A.

    Disable Columnstore Index:

    • Try disabling the columnstore index on the target table before running the copy activity. To do this, drop the columnstore index using the following command. Once done try to rerun and check if you face the same issue.
      DROP INDEX [index_name] ON [table_name]
      
    
    • If the above is not possible, try Merge method instead of upsert(if you use them).

    https://learn.microsoft.com/en-us/answers/questions/1402914/upsert-mode-of-copy-activity-causing-failure-for-d

    • Did you try using the clustered index?

    Please 'Upvote'(Thumbs-up) and 'Accept' as an answer if the reply was helpful. This will benefit other community members who face the same issue.

    1 person found this answer helpful.