Troubleshoot performance issues with the Oracle Database adapter

This section discusses using troubleshooting techniques to resolve performance issues that you might encounter when using Microsoft BizTalk Adapter for Oracle Database.

Known Issue

The following is the most common performance issue you might encounter when using the Oracle Database adapter, along with its probable cause and resolution.

Slowdown or stall in throughput when using the adapter with BizTalk Server

Problem

When using the Oracle Database adapter with BizTalk Server, the number of messages sent or received by the adapter slows down or comes to a stall.

Cause

The EnableBizTalkCompatibilityMode binding property is not set on the WCF-Custom send or receive port in BizTalk Server Administration console.

Resolution

Set the EnableBizTalkCompatibilityMode binding property to True. For more information about this property, see Read about the Oracle Database adapter binding properties. For instructions on how to set a binding property, see Configure the binding properties for Oracle Database.

Possible memory leak on a 64-bit computer when using the Oracle database adapter to perform operations involving FLOAT data type

Problem

You may experience a memory leak when using the Oracle Database adapter on a 64-bit computer to perform operations that involve FLOAT data types.

Resolution

Install .NET <version> (x64) on the 64-bit computer.

See Also

Troubleshoot the Oracle Database adapter.md