"Year End Close is still in process and batches cannot be posted" error when posting a transaction in General Ledger after the year is closed
This article provides a resolution for the issue that you can't post a transaction in General Ledger in Microsoft Dynamics GP after the year is closed.
Applies to: Microsoft Dynamics GP
Original KB number: 856550
Note
Before you follow the instructions in this article, make sure that you have a complete backup copy of the database that you can restore if a problem occurs.
Symptoms
When you try to post a transaction in General Ledger in Microsoft Dynamics GP after the year is closed, you receive the following error message:
Year End Close is still in process and batches cannot be posted.
Cause
This problem occurs because of invalid records that exist in the SY00800 table.
Resolution
To resolve this problem, delete the invalid records in the SY00800 table. To do this, follow these steps:
Have all users exit Microsoft Dynamics GP.
Open SQL Server Management Studio. To do this, select Start, point to All Programs, point to Microsoft SQL Server 20XX (XX=your version), and then select SQL Server Management Studio.
Run the following statement against the DYNAMICS database.
DELETE SY00800