Hello Sandz,
Welcome to the Microsoft Q&A forum.
This issue has been documented on the below Azure Synapse Link for Dataverse troubleshooting guide
<copied from the documentation page>
Error message: SYN-806: Default storage container in Synapse workspace isn't accessible
Root Cause:
Synapse workspace associated with this Azure Synapse Link profile doesn't contain a primary Azure Data Lake Storage Gen2 file system. The default storage container might be deleted or the default storage container isn't accessible. A default storage container is used by Synapse workspace as temporary storage in creating the file system. A default storage container must be provided when creating a Synapse workspace. It's possible that this storage container was deleted or no longer accessible.
Resolution:
Ask your administrator to launch Synapse workspace and verify the name of the primary Azure Data Lake Storage Gen2 file system. Also verify that an Azure Data Lake Storage Gen2 storage container exists with that name within the same subscription. If the storage container is missing, create a storage container with the same name.
Reference document:
https://learn.microsoft.com/en-us/power-apps/maker/data-platform/azure-synapse-link-troubleshooting-guide
I hope this helps. Please let me know if you have any further questions.
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