Scenario: Unable to create new Automation job in West Europe region
Issue:
When creating new Automation jobs, you might experience a delay or failure of job creation. Scheduled jobs will automatically be retired, and jobs executed through the portal can be retired if you see a failure.
Cause:
This is because of the high load from customers' runbooks using the Automation service in the West Europe region.
Resolution:
Perform the following action if it is feasible as per your requirement and environment to reduce the chance of failure:
- If you’re using the top of the hour for the job creation (at 12:00, 1:00, 2:00, and so on.), typically on the hour, or half hour, we recommend that you move the job start time to five minutes before or after the hour/half hour. This is because a most of the customers use the beginning of the hour for job execution which drastically increases the load on the service, while the load is relatively low at the other time slots.
Note:
The optimization of existing load and transitioning the load to a new design by the product group is in progress and the ETA for it is end of calendar year CY22.
Related information is now provided in the below mentioned Azure Automation FAQ document and/or Troubleshooting document:
Azure Automation FAQ | Microsoft Learn
Troubleshoot Azure Automation runbook issues | Microsoft Learn