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Word Online Edit in Word not working when using Edge on Windows 10

Anonymous
2017-01-25T00:22:13+00:00

I am using an Office 365 for business account and looking at documents stored in One Drive for business and SharePoint online. I get the following prompt when choosing "Edit in Word"

In addition to failing to launch Word 2016, there is no option to manual select Word 2016.

If I use Internet Explorer 11 instead, this works: it opens Word 2016, with the document open.

If I open Word 2016, I can browse to the file (on OneDrive / SharePoint) and open it.

This used to work in Edge. A colleague sees the same issue (used to work, and no longer does).

I am using Word 2016 installed from the www.office.com "Install Office 2016" link.

In my windows settings the ms-word protocol shows no default, and presents the same unhelpful app store dialog

Resetting to Microsoft recommended results does not help.

Likewise setting defaults by app, choosing Word 2016 and either

  1. Set this program as default
  2. Choose defaults for this program, and click "Save" with the MS-WORD protocol selected

Has no effect.

I'm looking for a way to get this working again, or a confirmation that this is a bug that will be fixed.

Microsoft 365 and Office | Word | For home | Windows

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Answer accepted by question author

Anonymous
2017-03-24T07:55:22+00:00

Hi Evan,

Glad to know that the issue is resolved. I’d like to make a summary here so this can help other community members who run into the same issue quickly find out the solution.

Issue Description:

When clicking “Edit in Word” via Word Online, there is no option to choose Word application in prompted windows. This issue happens when using Edge/Chrome/Firefox, but IE opens the documents in Word client successfully.

The default app for the MS-WORD protocol via Settings in Windows 10 is showing as no entry.

Root cause:

There exists other Office component (Microsoft Office Professional Plus 2016 – en-us)

Solution:

Remove/uninstall other Office components in the computer.

Regards,

Ryan

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  1. Anonymous
    2017-01-26T23:06:34+00:00

    > 1. Remove the folder in %LocalAppData%\Packages\Microsoft.MicrosoftEdge_8wekyb3d8bbwe

    This was very poor advice. Please don't give people this advice in the future. After completing this step Edge would no longer start. I would get the splash screen, which would disappear, and then nothing.

    I eventually restored Edge following instructions here:

    http://www.intowindows.com/how-to-reinstall-microsoft-edge-in-windows-10/

    Anyway, in for a penny... here is the rest

    > 2. Click three dots at the right corner of Edge > Settings > Clear Browse Data, choose what to clear part

    I opened edge, went to Edge > Settings > Clear Browser Data, select "show more" and ticked every box, and then Clear.

    I then retried the "Edit in Word" and see the same problem (as described in the original description)

    > you still can't open in Word, please confirm the following information:

    > 1. Try to open the PowerPoint or Excel documents in client application in Edge and share the result with us.

    The "Edit in PowerPoint" action in PowerPoint online appears to work correctly, and opens PowerPoint on my PC with the presentation.

    The "Edit in Excel" action in Excel online appears to work correctly, and opens Excel on my pc with the spreadsheet.

    > 2. When does this behavior occurs?

    I may not understand this question --- I think this is covered in the original description, but here are some screenshots of the action I'm taking in Word Online. The problem occurs both in Reading view and Editing view. For Reading view the problem occurs regardless of whether Accessibility Mode is on or off (for some reason it defaults to on, which is a separate issue I'm having)

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  2. Anonymous
    2017-01-26T11:15:29+00:00

    Hi Evan,

    Based on your description, please try resetting Edge to check the result.

    1. Remove the folder in %LocalAppData%\Packages\Microsoft.MicrosoftEdge_8wekyb3d8bbwe
    2. Click three dots at the right corner of Edge > Settings > Clear Browse Data, choose what to clear part

    If you still can't open in Word, please confirm the following information:

    1. Try to open the PowerPoint or Excel documents in client application in Edge and share the result with us.
    2. When does this behavior occurs?

    Regards,

    William

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  3. Anonymous
    2017-01-25T11:26:34+00:00

    Thanks for your quick reply Tim,

    I followed the steps to "Set this program as default" but I still have the same problem

    Steps.

    1. Followed Control Panel directions provided, clicked Set this program as default, then clicked OK
    2. Closed the control panel, closed all browser windows, logged out of Windows 10
    3. Logged back into Windows 10,
    4. Opened Edge, and opened a document in Word Online (stored in SharePoint online)
    5. Selected the Edit in Word option.

    Result: same prompts as shown in the original description.

    In answer to your questions.

    1. Open Word, click File>Account>capture a screenshot of all information under Product Information.

    1. Do you mean the issue is only related to Edge? Can other browsers open documents in Word?

    Edge is currently my default browser

    When I try in the following browsers I see:

    • IE11 - successfully opens the document in Word 2016 (after a warning about opening files from the internet).
    • Chrome - fails (I get the All Done dialog along with a chrome dialog asking if I'd like to "Open URL:Word Protocol", clicking open does nothing
    • Firefox - fails (similar to chrome), but provides me with the option of manually selecting an executable, if I select the word application it opens Word 2016 but fails to open the document with the message "Sorry, we couldn't open 'ms-word:ofe|u|https"//ex***al.sharepoint.com/...
    1. When you double click a local file, does Word launch properly?

    If I open Windows Explorer and double click on a .docx on my local C: then it opens in Word 2016 correctly. The same is true if I double-click on a .docx in a synced sharepoint document list.

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  4. Anonymous
    2017-01-25T09:20:41+00:00

    Hi Evan,

    You may navigate to Control Panel\Programs\Default Programs\Set Default Programs, find Word 2016 and then click Set this program as default.

    If it doesn’t work, I’d like to confirm the following things:

    1. Open Word, click File>Account>capture a screenshot of all information under Product Information.
    2. Do you mean the issue is only related to Edge? Can other browsers open documents in Word?
    3. When you double click a local file, does Word launch properly?

    Best regards,

    Tim

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