How to bypass the edge://welcome-new-device page ?

Paul USUBELLI 145 Reputation points
2025-04-07T14:33:59.02+00:00

Hello there,

An employee can't reach edge at the edge first start, this error message appears :User's image

We have already checked on the edge policies, and the HideFirstRunExperience policy is set up on true.

Can you help us to troubleshoot this issue please ?

Many thanks in advance.

Kind regards,
Paul

Microsoft Edge | Microsoft Edge development
{count} votes

Accepted answer
  1. Sven Taelman 75 Reputation points
    2025-04-09T08:00:44.2633333+00:00

    We solved the problem by sign out the user from his egde profile. let him login again, a new profile will be created in the edge browser. Afterwards we singed out the user again, did a cleanup from all the edge profiles, and let the user sign-in again, a new profile (Profile 1) will be created. We closed edge en restarted the pc, let the user sign-in again en open th edge browser withou any issues.

    0 comments No comments

5 additional answers

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  1. CS IT 40 Reputation points
    2025-04-08T09:14:13.86+00:00

    Our workaround was to reset the registry key SOFTWARE\Policies\Microsoft\Edge HideFirstRunExperience from 1 back to 0. The user had to unnecessarily click through the introduction, but then it worked.

    8 people found this answer helpful.

  2. MC Red 35 Reputation points
    2025-04-09T13:59:03.94+00:00

    Hi, same issue here, but different and maybe easier solution..(offcourse, configurations may differ, but just give it a try);

    .

    1. If you open Edge and the Url error appears, go to you taskbar on the openend Edge icon and use your right mouse button. You'll get options as shown below. Open here Edge again. This time, Edge wil open another browserpage, working correctly.

    User's image

    1. Go to the tree dots on the right site of the browser to get the Edge options menu. I have a dutch

    version, but should look somewhat like the image below. Choose the 'close edge' option. That's it. It even closed the first page with the URL error without using the taskmanager. After restarting edge directly, everything worked just fine again.... Hope it helps...

    User's image

    7 people found this answer helpful.

  3. Greg D 5 Reputation points
    2025-04-08T08:12:14.4166667+00:00
    Causes
    The "sign-in" is due to EU laws, see https://techcommunity.microsoft.com/blog/windows-itpro-blog/upcoming-changes-to-windows-single-sign-on/4008151
    
    Verification
    Accounts > Email and Accounts > Verify that the work account has been added
    
    Workaround
    In "C:\windows\system32\IntegratedServicesRegionPolicySet.json", search for "Automatic app sign-in" and delete your region (BE) under "disabled".
    
    1 person found this answer helpful.

  4. Loïck Dupont 0 Reputation points
    2025-04-08T07:41:30.08+00:00

    Same problem here. See also Reddit post https://www.reddit.com/r/sysadmin/comments/1jtjt79/comment/mlvg6ob/

    Still not listed on known issues page yet, so please make cases:
    https://learn.microsoft.com/en-us/deployedge/microsoft-edge-known-issues?tabs=Open


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