Unable to add more than one DAG member server in Exchange Server 2019.

asked 2020-09-21T07:59:04.893+00:00
Michael Wiskman 106 Reputation points

From EAC, creating DAG itself worked with no issues. Then we went ahead and added first mailbox server to the DAG without problems. This is where the problems begin. We are unable to add more servers.

A server-side database availability group administrative operation failed. Error The operation failed. CreateCluster errors may result from incorrectly configured static addresses. Error: An error occurred while attempting a cluster operation. Error: Cluster API failed: "AddClusterNode() (MaxPercentage=100) failed with 0x5b4. Error: This operation returned because the timeout period expired". [Server: server.domain.com]

Event 1146 Microsoft-Windows-FailoverClustering
The cluster Resource Hosting Subsystem (RHS) process was terminated and will be restarted. This is typically associated with cluster health detection and recovery of a resource. Refer to the System event log to determine which resource and resource DLL is causing the issue.

We have been following this article https://www.xpertstec.com/how-to-configure-a-database-availability-group-dag-in-exchange-server-2019/

CNO has Exchange Trusted Subsystem assigned with “Full Control”
Local Administrator Group has Exchange Trusted Subsystem assigned with “Full Control”
The Cluster Name can update the DNS record.

Exchange Server Management
Exchange Server Management
Exchange Server: A family of Microsoft client/server messaging and collaboration software.Management: The act or process of organizing, handling, directing or controlling something.
6,072 questions
No comments
{count} votes

4 answers

Sort by: Most helpful
  1. answered 2020-09-22T01:56:09.367+00:00
    Yuki Sun-MSFT 24,476 Reputation points

    Hi @Michael Wiskman ,

    Then we went ahead and added first mailbox server to the DAG without problems. This is where the problems begin. We are unable to add more servers.

    Were all the mailbox servers built using a same base image which has been installed with all the prerequisites including Failover Cluster Manager? If this is the case, it's suggested to try removing and reinstalling the Failover Cluster Manager feature for the other mailbox servers you want to add into the DAG and see if the error can be resolved. The Failover Cluster Manager feature can be removed and installed via the Server Manager:
    26246-1.png

    Here is a blog with the same error message for reference: Incorrectly Configured Static Address when creating a DAG.
    Please Note: Since the web site is not hosted by Microsoft, the link may change without notice. Microsoft does not guarantee the accuracy of this information.


    If an Answer is helpful, please click "Accept Answer" and upvote it.
    Note: Please follow the steps in our documentation to enable e-mail notifications if you want to receive the related email notification for this thread.


  2. answered 2020-09-24T11:54:26.743+00:00
    Ashok M 6,376 Reputation points

    Hi,

    Can you please try the below steps and see if that helps,

    1. Is there any firewall between the exchange servers? - If so, try allowing Any-any rule between the exchange servers and add it again
    2. Turn off windows firewall if its on and try
    3. Uninstall the failover cluster manager, disable IPv6 using registry, reboot the server and then try adding it

    Disabling IPv6 using registry, HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\services\TCPIP6\Parameters
    Set DisabledComponents to ffffffff

    Please Note: Take the backup of the registry before making changes and be careful in the changes as the improper configuration would lead to other issues.

    Also, its not recommended to disable IPv6, this is only for addressing this issue and check if this resolves. I fixed the similar issue in an environment by disabling IPv6 and once the node is added successfully, I re-enabled it again.

    No comments

  3. answered 2020-09-24T12:22:53.843+00:00
    Michael Wiskman 106 Reputation points

    Thank you for your answers. As I said, have tested most things. Has now escalated it to Microsoft Support. I will write here if they find the solution. Then it can always be helpful to someone else.


  4. answered 2021-01-19T21:22:09.007+00:00
    Joseph Larrew 326 Reputation points

    This is a little late to the game, but this helped me. Under "Computer Configuration...>User Rights Assignment" change the setting "Deny access to this computer from the network" to make sure "Local Accounts," or the like, is not in there.

    No comments