Unable to change email for some hybrid mail-enabled groups

Jon Hall 21 Reputation points
2022-09-20T21:04:44.163+00:00

Our organization (Hybrid AD, only Exchange Online) is migrating to a new domain (.com to .gov) for our email. We've successfully migrated all user accounts, retaining the old address in Proxy, but some of the mail-enabled security groups are being difficult. I set the Mail field to the new address and update ProxyAddresses as smtp:{old address}; SMTP:{new address}. I force a delta sync and verify that the changes show in both the AAD Audit Logs and Synchronization Manager on the server. When I refresh Exchange Online it shows the Group Email (mail-enabled security) with the address; however, as soon as I click on the row to open and verify, that field in the listing changes to the old address and it shows as a distro group. The Primary address still has the old address and the new address isn't listed under Aliases. It doesn't seem to matter whether I have the new address as an alias at the beginning or not. As a test I've left everything with the old address and simply added the new address as an alias (smtp), but it never shows in Exchange and bounces back as unreachable.

I've successfully migrated two of the problem groups, but it seems to be completely random. On those two I had tried the steps that worked a dozen times until it finally magically worked. Because these groups are on-premises and synched up I can't make the changes in Exchange. No amount of time seems to help. When it worked, it worked immediately and unexpectedly.

243192-image.png
243136-image.png

Thank you!
Jon

Microsoft Exchange Online Management
Microsoft Exchange Online Management
Microsoft Exchange Online: A Microsoft email and calendaring hosted service.Management: The act or process of organizing, handling, directing or controlling something.
4,228 questions
Microsoft Entra ID
Microsoft Entra ID
A Microsoft Entra identity service that provides identity management and access control capabilities. Replaces Azure Active Directory.
19,768 questions
0 comments No comments
{count} votes

Accepted answer
  1. Andy David - MVP 142.6K Reputation points MVP
    2022-09-20T22:27:12.847+00:00

    Hi there. Have you removed the object from Azure and re-synced?


1 additional answer

Sort by: Most helpful
  1. KyleXu-MSFT 26,211 Reputation points
    2022-09-21T05:55:27.94+00:00

    @Jon Hall

    For a synced group, it will show as below, you could see (You can only manage this group in your on-premises environment. Use 'Active directory users & groups' or 'Exchange Admin Center' tools to edit or delete this group.):

    243293-1.png

    For Exchange online hosted group, you could see the "edit":
    243304-2.png

    For your group, I think it hosted on Exchange online, you could try to click the "edit" to modify email address for this group.

    We can also it is synced with local AD, I think this phenomenon caused by AD and Azure account conflict. You could try to delete the local AD account, check whether it show as Exchange online hosted group.

    It is suggested you delete this group from both Exchange online and Exchange on-premises, then create a new one.


    If the answer is helpful, please click "Accept Answer" and kindly upvote it. If you have extra questions about this answer, please click "Comment".
    Note: Please follow the steps in our documentation to enable e-mail notifications if you want to receive the related email notification for this thread.


    0 comments No comments