Private DNS Resolver - Inbound endpoint fail to deploy - Conflict

Tarjei Ylvisåker 56 Reputation points
2022-09-20T21:02:22.957+00:00

Greetings,

I am trying to set up Private DNS Resolver with a inbound endpoint, but it keep failing. Region = West Europe.
I can create the Private DNS Resolver, but not provision the Inbound Endpoint.

I have tried to

  • Let the Portal-workflow create the subnet for me, a /24 in the scope within the VNET
  • Created a dedicated /24 subnet manually and tried to use that
  • Edited the above subnet to /28 and tried to use that
  • Deleted everything and tried once more

Error:

{  
    "status": "Failed",  
    "error": {  
        "code": "InternalServerError",  
        "message": "Failed to allocate inbound endpoint. inboundEndpointResourceId=/subscriptions/xyz/resourceGroups/my-networking-rg/dnsResolvers/mydnspr/inboundEndpoints/pdnsinendpoint, endpointResourceGuid=xyz, virtualNetworkResourceGuid=xyz, subnetResourceId=/subscriptions/xyz/resourceGroups/my-networking-rg/providers/Microsoft.Network/virtualNetworks/my-vnet/subnets/my-dedicated-subnet"  
    }  
}  

The error really is not giving me much to work on. The status says conflict. There are no VMs or similar in the VNETs.

243185-image.png

Azure DNS
Azure DNS
An Azure service that enables hosting Domain Name System (DNS) domains in Azure.
605 questions
{count} votes

Accepted answer
  1. msrini-MSFT 9,261 Reputation points Microsoft Employee
    2022-09-21T17:05:48.68+00:00

    Hi,

    I checked with the team and looks like there is a known issue going on in West Europe. You can trigger a new deployment once the issue is resolved. Hopefully you can try it in a day or so.

    Regards,
    Karthik Srinivas


0 additional answers

Sort by: Most helpful