question

gsanjay-4624 avatar image
0 Votes"
gsanjay-4624 asked AJTek-Adam-J-Marshall answered

wsus connection error



I am getting in wsus like: error :connection error in WSUS

Its asking for reset server node to try to connect to the server again

Please find the attached image

HOW to solve this issue
243464-image.png


windows-serverwindows-server-iiswindows-server-update-services
image.png (93.1 KiB)
5 |1600 characters needed characters left characters exceeded

Up to 10 attachments (including images) can be used with a maximum of 3.0 MiB each and 30.0 MiB total.

AJTek-Adam-J-Marshall avatar image
0 Votes"
AJTek-Adam-J-Marshall answered

Are you performing the proper WSUS maintenance including but not limited to running the Server Cleanup Wizard (SCW), declining superseded updates, running the SQL Indexing script, etc.?

https://www.ajtek.ca/wsus/how-to-setup-manage-and-maintain-wsus-part-8-wsus-server-maintenance/

5 |1600 characters needed characters left characters exceeded

Up to 10 attachments (including images) can be used with a maximum of 3.0 MiB each and 30.0 MiB total.

YurongDai-MSFT avatar image
0 Votes"
YurongDai-MSFT answered YurongDai-MSFT commented

Hi @gsanjay-4624,

The quickest solution to get Windows Update in WSUS working again is to restart the server. When the frequency went up, I was able to catch one of the instances and do some troubleshooting. Although I can't get into the console on the server, I see that the WSUS service reports fine. If I execute the "iisreset" command, everything starts working again. This helps resolve issues quickly.

There are threads reporting similar issues. The main symptom is that the IIS worker process consumes more RAM than is available. The default limit is set to 1843200KB or 1.8GB. When the problem occurred, the IIS worker process was using more than 2GB of RAM. My server had more RAM available so the solution was to raise the amount of memory available to IIS. Steps as follows:
1. Open IIS and select Application Pool.
2. Right-click on the WsusPool and select Advanced Settings.
3. Change the Private Memory Limit (KB) to a higher number that fits your server specifications or ‘0’, which means no limit, instead of the hard-coded 1843200.
4. Go back under Application Pools, right-click on the WsusPool again and select "Recycle..."

Maybe when you try restarting all the required services, the problem will get resolved.


If the answer is the right solution, please click "Accept Answer" and kindly upvote it. If you have extra questions about this answer, please click "Comment".
Note: Please follow the steps in our documentation to enable e-mail notifications if you want to receive the email notification for this thread.

Best regards,
Yurong Dai









· 2
5 |1600 characters needed characters left characters exceeded

Up to 10 attachments (including images) can be used with a maximum of 3.0 MiB each and 30.0 MiB total.

this is i tried but not working , again getting same issue

0 Votes 0 ·

Hi @gsanjay-4624,
Please check your event viewer. What errors are you seeing? And what is the corresponding event ID?

0 Votes 0 ·
AJTek-Adam-J-Marshall avatar image
0 Votes"
AJTek-Adam-J-Marshall answered

You always have the option to re-install WSUS

https://www.ajtek.ca/wsus/how-to-remove-wsus-completely-and-reinstall-it/

5 |1600 characters needed characters left characters exceeded

Up to 10 attachments (including images) can be used with a maximum of 3.0 MiB each and 30.0 MiB total.