Azure Backup : Autoprotect is not working for AAG

sakuraime 2,316 Reputation points
2020-09-22T03:43:24.877+00:00

Autoprotect is not working for AAG , added new database to the AG , but the next backup schedule is not including the backup of the database. (test3 was added to the AG)

26228-autoprotect.jpg

26333-autoprotect2.jpg

SQL Server on Azure Virtual Machines
Azure Backup
Azure Backup
An Azure backup service that provides built-in management at scale.
1,076 questions
0 comments No comments
{count} votes

1 answer

Sort by: Most helpful
  1. SadiqhAhmed-MSFT 35,326 Reputation points Microsoft Employee
    2020-09-22T12:24:10.863+00:00

    Hi @sakuraime , thank you for reaching out to us!

    A database that you add to an autoprotected instance might not immediately appear under protected items. This is because the discovery typically runs every 8 hours. However, you can discover and protect new databases immediately if you manually run a discovery by selecting Rediscover DBs.
    Refer to the FAQ page - https://learn.microsoft.com/en-us/azure/backup/faq-backup-sql-server#why-cant-i-see-an-added-database-for-an-autoprotected-instance

    Also, you can comment on this feedback item - https://feedback.azure.com/forums/258995-azure-backup/suggestions/37176106-autoprotect-does-not-work-for-me-when-i-add-a-new and up-vote the request.

    ------------------------------------------------------------------------------------------------------------------------------

    Please do not forget to "Accept the answer" and "Up-Vote" wherever the information provided helps you to help others in the community.