Error 0x80070005

Ettore Filippi 56 Reputation points
2022-09-25T13:41:28.487+00:00

Hi everyone.

I've been having this problem for a while and can't seem to fix it so after trying with Microsoft Community with little result I decided to try here. Don't really know if it's the place for more user-side problems but I figured I'd give it a try.

Basically, certain applications, seemingly all system ones (at the moment Groove Music, now called "Media Player" on the Store, Movies and TV and Photos), simply can't update to their latest versions because of the error i cited in the title, which happens after a couple seconds of the Store trying to install the app, after completing its download.

The main problem is related to the Photo app though. It originally wouldn't update and would weirdly only display the english language, while the rest of the system is in italian, so I tried resetting it and finally uninstalling it by removing its two main components from Windows' Settings to see if it would yield any result on the Store side.

What I ended up doing is leaving my system with neither a way of rapidly opening and viewing pictures or reinstalling the Photos app, which behaves exactly the same as the other two with the exception i'm trying to get it on my system instead of just updating it.

I already tried resetting the Store's cache and updating it but it didn't work. The troubleshooter also didn't give results and trying to remove and reinstall the Photo's app package through Powershell didn't work too.

An interesting thing is that the Photos app exists and works on my secondary user account, kinda leading to the conclusion my main account is at fault here. I don't understand what could be going on though. Thanks in advance and sorry for the weird spacing but my keyboard is also facing problems lol.

Windows 10
Windows 10
A Microsoft operating system that runs on personal computers and tablets.
10,814 questions
{count} votes

8 answers

Sort by: Most helpful
  1. Limitless Technology 44,011 Reputation points
    2022-09-28T08:45:16.273+00:00

    Hello EttoreFilippi,

    The error 0x80070005 occurs when the system or user lacks the required files or permissions to change settings at the time of the Windows update.

    Here is some troubleshooting that might fix this problem.

    Solution 1
    Check if doesn't have any corrupt files on the windows.
    1-Right-Click on Start then click on Windows Powershell (admin)
    2- Type these commands.
    sfc /scannow (and press Enter)
    Dism /Online /Cleanup-Image /ScanHealth (and press Enter)
    Dism /Online /Cleanup-Image /CheckHealth (and press Enter)

    3- The DISM tool will report whether the image is healthy, repairable, or non-repairable. If the image is repairable, you can use the /RestoreHealth (Dism /Online /Cleanup-Image /RestoreHealth) argument to repair the image.

    Solution 2
    It might be that something went wrong with the update files itself. Clearing the folder where all of the
    update files are stored will force Windows Update to download fresh files.
    Here how to clear update database cache, reset windows update components to the default setup.

    1-Press Windows + R, type services.msc and ok to open windows services.
    2-Scroll down and look for windows update service.
    3-Right-click on it and select stop.
    4-Also, do the same with BITs (Background Intelligent Transfer Service) and Superfetch (superfetch now called sysmain) right-click and select stop.
    5-Now Go to the following location C:\Windows\SoftwareDistribution\Download.
    6-Delete everything inside the download folder, but do not delete the folder itself.
    To do so, press CTRL + A to select everything and then press Delete to remove the files.
    Again open windows services and restart the services (windows update, BITS) which you previously stopped.
    7-Reboot and try again

    Solution 3
    Reinstall the Microsoft Store.
    1-Right click on Start.
    2-Click on Windows PowerShell(admin)
    3-Type:
    Get-AppXPackage -allusers | Foreach {Add-AppxPackage -DisableDevelopmentMode -Register "$($_.InstallLocation)\AppXManifest.xml"} and press ENTER.
    4-Reboot your pc and try open the Microsoft Store.

    Solution 4
    If none of the procedures fix the problem, you can perform the repair upgrade using the Media Creation tool, this procedure will repair all Windows files.
    1-Download the media creation tool.
    https://go.microsoft.com/fwlink/?LinkId=691209
    2-Run the tool and select 'Upgrade this pc now'
    3-Select the option 'Keep all my files and apps'
    4-Then click to update.

    ------------------------------------------------------------------------------------------------------------------------------------------------------

    --If the reply is helpful, please Upvote and Accept as answer--

    5 people found this answer helpful.

  2. Ettore Filippi 56 Reputation points
    2024-02-11T02:39:24.97+00:00

    Don't know if anyone's still reading but I saw some new activity on this thread and I myself have had to come to terms with this problem again these days so I thought It'd be right to update it.

    I've understood the code stands for some kind of missing permission that denies the system access to components needed to finalize whathever process it's trying to perform, but it can be given out by Windows in a variety of situations and I guess solutions will look entirely different for similar cases even.

    Mine had to do with the installation and updating of certain apps through the Microsoft Store. As I intially said, the system apps Photos, Media Player and Movies & TV would't update and remained in a constant error state in the Store's app view. The problem became worse when I experienced the exact same thing (error code 0x80070005 during the install phase) trying to get the new native Apple Music app and even the older iTunes one through the Store. The code unfortunately didn't give much information and I couldn't find a lot even in the once richer Event Viewer, which reported an installation problem happening but had pretty much the same depth as the message on the Store.

    What I tried was trying to install the app directly from its .msix package downloaded from a pretty interesting website that appears to be fetching data straight from MS Store's servers. If you try opening such a package Windows will try to register it using an app installer separate from MS Store that actually gives some info on the error, which repeated with the same code but specified there was a problem with a certain "windows.fileTypeAssociation" extension and also referenced a precise point in the package's AppManifest, a document located inside it and viewable opening the .msix with a program like 7zip. I'm not an expert but there were references to this "fileTypeAssociation" function and a list of file extensions at the line and column specified in the error message.

    The fundamental solution was going to the registry and then accessing the folder containing keys for basically any supported file format storing informations such as the programs that can open each, "HKEY_CURRENT_USER/SOFTWARE/Classes". I then selected every file format present in the problematic part of the AppManifest and found some of them actually had pretty fitting authorizations issues: existing keys couldn't be accessed or modified and new ones obviously couldn't be added, what was probably making the installation impossible. Changing the file extensions key security settings to "Complete Control" for the entity "Every App Package" miracolously had its effect and finally seemed to solve the issue. Trying the update or install process of the previously cited Apps from the Microsoft Store finally worked.

    Don't know what exactly happened to the registry permissions and why but that's what I'm surely going to check first if anything like this happens again and what I can only suggest doing. Hope this can help and thanks for the numerous replies.

    1 person found this answer helpful.
    0 comments No comments

  3. S.Sengupta 15,766 Reputation points MVP
    2022-09-26T00:23:14.57+00:00

    Open Command Prompt and select the Run as administrator option.

    Type the following DISM command to repair corrupted system files and press Enter:

    dism.exe /Online /Cleanup-image /Restorehealth
    Type the following SFC command to repair system files and press Enter:

    sfc /scannow

    ========================

    0 comments No comments

  4. Ettore Filippi 56 Reputation points
    2022-09-26T15:57:44.1+00:00

    Hi and thanks for the response.

    I already tried running an sfc scan a couple days ago and it didn't yield any particular result but I didn't know about DISM so I tried that one out as well but it unfortunately didn't fix the problem.

    I really don't understand what could be going on here. The really weird thing is that as I said all of the apps i'm having problems with on my main account (which aren't the entirety of Microsoft Store apps by the way, just the three I cited for now) work and are perfectly downloadable and updatable on the secondary one, even the Photos app I can't even find in Windows Search on the other one. It seems it's the main profile's User folder that's interfering somehow even if my limited knowledge in the field of UWP apps and how they intgrate with the system and are managed between different users doesn't really let me to go any further at the moment. I just know most of the Store's app are placed in the WindowsApps folder which should be shared between all accounts so I don't get it.


  5. Ettore Filippi 56 Reputation points
    2022-10-06T11:39:32.167+00:00

    Sorry for the delay but I've been a bit busy these days.

    I tried performing the fixes you suggested but they unfortunately didn't solve the issue, at least directly.
    Running that last Powershell command did provide some additional informaton on the problem, even if I haven't really been able to make all that much use of it, hope you guys can help.

    The registering process went fine for most of the packages except, probably not coincidentally, for the ones that the Microsoft Store can't install citing the usual error code. Looking at the log for the unsuccessful registration of the Photos app it gives the same "0x80070005" error code already seen in the store and says it's coming from the also unsuccesfull registration of a windows.fileTypeAssociation extension in the package's manifest (it also gives the precise location of the error in the text of the .xml file and it does coincide with an extension declaration) because of "denied access".

    I've tried looking around a bit and all the manifest's doing is specifiying which file types the app is going to be suitable for, without making references to specific files or entities the system could have problems accessing. The only thing that comes to my mind is a problem with giving the app compatibility with the file types themselves, but I don't know.

    0 comments No comments