Sharepoint 2019 Modern Experience and Content Types

Nathan 1 Reputation point
2020-09-22T10:33:23.733+00:00

We recently upgraded from SP 2013 to SP2019. We have no issues when using classic experience on libraries (migrated or newly created). When using Modern Experience we encounter issues when creating new office documents from Content Types (Excel, word etc) When users create the document, Excel (for example) opens and prompts for credentials, if a user closes the prompt the Excel document opens up as normal. If they enter a password they are presented with a warning that: "The file format and extension 'templatename.htm' don't match. The file could be corrupted or unsafe. Unless you trust thd source dont open it. Do you want to open it anyway?" If the user clicks "Yes" to this the file opens as normal. We also see a password prompt whenever a user tries to access the Sharepoint Properties Pane in Word. This is really annoying as can prevent users inputting required Sharepoint metadata which then results in the created file not checking in properly for a period of about 15 minutes. We dont see any other security / user issues, and ULS logging doesnt show this at all. Is there a config that needs changing on clients or server to allow files to open correctly from Modern and for us to authenticate the users to use the Sharepoint Properties Pane? This happens in any browser. But we mainly use Edge (latest build) with force to open in IE 11 mode. Office is all o365 pro monthly channel and up to date.

SharePoint Server
SharePoint Server
A family of Microsoft on-premises document management and storage systems.
1,454 questions
SharePoint Server Management
SharePoint Server Management
SharePoint Server: A family of Microsoft on-premises document management and storage systems.Management: The act or process of organizing, handling, directing or controlling something.
2,360 questions
{count} votes

1 answer

Sort by: Most helpful
  1. JoyZ 17,901 Reputation points
    2020-09-23T07:56:17.013+00:00

    Hi @Nathan ,

    Please make sure you have activated office 365.

    Then add the site to excel Trusted location via File> Options> Trust Center> Trust Center Settings> Trusted locations> Add new location to compare the result:

    26855-image.png


    If an Answer is helpful, please click "Accept Answer" and upvote it.

    Note: Please follow the steps in our documentation to enable e-mail notifications if you want to receive the related email notification for this thread.