Cloud Management Gateway stuck provisioning

Lee 96 Reputation points
2020-09-22T12:27:59.47+00:00

Hi,

I am setting up a Cloud Management Gateway in ConfigMgr, but have hit a problem where the service has been stuck in the "Provisioning - deploying service" stage for ~24 hours now.

Looking in the Azure portal it seems to be up and running, and I am even able to distribute content to it from ConfigMgr. However as it still shows as provisioning in the ConfigMgr console, I can't initialise a syncronisation or anything.

Nothing has happened in the CMGSetup or CMGService logs in 24h. The last entries show "Added or updated endpoint..." and "Certificate xxx found" but nothing since.

The CloudMgr log seems to be looping every minute with the following:

Start to poll cloud service tasks from DB
0 tasks running, 0 tasks waiting to start
Current CMG deployment hash is ***
CreateUpgradeTaskForPackageChange: Triggered to create upgrade task for service type CloudProxyService with current package hash ***
Starting task CloudServicesTaskBuilder
CloudServicesTaskBuilder is running
CloudServicesTaskBuilder: stopping
1 task running, 0 tasks waiting to start
Task CloudServicesTaskBuilder status is RanToCompletion
Removing task CloudServicesTaskBuilder from running tasks

Any thoughts on how to further troubleshoot this would be much appreciated.
Thanks!

Microsoft Configuration Manager
0 comments No comments
{count} votes

Accepted answer
  1. Lee 96 Reputation points
    2020-10-26T09:25:25.79+00:00

    This issue was finally resolved. The CMG was stuck in a provisioning stage, but forcing a stop from the Azure portal and by running the "Stop-CMCloudManagementGateway" PowerShell command before restarting them both again allowed the service to complete the provisioning phase and be ready for use.


1 additional answer

Sort by: Most helpful
  1. Simon Ren-MSFT 28,556 Reputation points Microsoft Vendor
    2020-09-23T08:26:51.317+00:00

    Hi,

    Thank you for coming Microsoft MECM Q&A forum.

    1.May we know which version of Configuration Manager you are using? If you are using version 1702, please install the KB 4033015, if using another version, please install the latest hotfix to have a try.
    Provisioning not completed when creating a Cloud Management Gateway in System Center Configuration Manager version 1702

    2.Please help check if the prerequisites are met:
    Set up cloud management gateway for Configuration Manager

    Thanks for your time.

    Best regards,
    Simon