Pipeline Deployments Fail: No space left on device

Anonymous
2022-09-27T20:13:03.94+00:00

I'm using Azure DevOps Pipelines with a self hosted build agent to deploy to App Services. We occasionally get "No space left on device" errors that result in deployment fails.

It seems somewhat random when we receive these errors, so we're having trouble figuring out what the cause is.

We scheduled a maintenance job to clean up records, but are still occasionally running in to the issue. The failures tend to happen more often in the mornings 8AM-10AM EST and after 4PM, but its random enough I'm not sure if that's relevant. I've also had a Saturday with pretty consistent fails. Eventually the deployments start working again with no intervention on our end.

Any insight in to what is going on or potential solutions would be greatly appreciated.

Not Monitored
Not Monitored
Tag not monitored by Microsoft.
36,484 questions
0 comments No comments
{count} votes

Accepted answer
  1. Takahito Iwasa 4,841 Reputation points MVP
    2022-09-27T22:15:17.58+00:00

    Hi, @Anonymous

    Your question sounded like a problem with using self-hosted agents in Azure DevOps.

    Currently, Azure DevOps is not supported on Microsoft Q&A.

    The Azure DevOps team and community are active and answering questions on https://developercommunity.visualstudio.com/spaces/21/index.html Please post your question there and experts will guide you.

    You can also ask for help : https://stackoverflow.com/questions/tagged/azure-devops.
    https://developercommunity.visualstudio.com/search?space=21

    0 comments No comments

0 additional answers

Sort by: Most helpful