Donated Dell Laptops not connecting to Domain Wifi

NonProfit 1 Reputation point
2022-09-28T21:17:09.273+00:00

Hello, we have been donated Dell E7470s laptops to our nonprofit without any OS. We have installed the Win10 Pro OS and joined our Domain but when we attempt to connect to our internal domain Wi-Fi network they cannot connect. They connect fine the the guest Wi-Fi network or any other Wi-Fi hotspot. I get a prompt with username and password. This should automatically be populated via GP and does not happen with any other new laptop or reconfigured laptop only these donated machines.

All new laptops and a few of these have connected fine to the same Wi-Fi network but we struggle with quite a few of them. We have done the following to rule out some issues:

  1. Swapped Wi-Fi cards
  2. Swapped Hard Drives
  3. Connected to any other Wi-Fi network (successfully)
  4. These have an internal SmartCard reader
  5. We have joined and disjoined the domain successfully but they won't connect regardless.
  6. It was missing a Root Certificate Authority (which we imported to Trusted Root..)

All Wi-Fi settings are defined by our Group Policy (Windows 2016 Domain) and all other computer connect perfectly without issue but these Dell's do not.

I see on our domain controller the following message: The client certificate for the user Domain\ComputerName$ is not valid, and resulted in a failed smartcard logon. Please contact the user for more information about the certificate they're attempting to use for smartcard login. The chain status was: The operation completed successfully.

Questions:

  1. Maybe the smartcard reader is locked for the previous companies domain?
  2. I have tried importing the Root Certification Authority Certificate since it was missing but this still doesn't work. Could it be that a certificate is missing?

Any help would be appreciated. These are a great help to our programs but they will be useless if I cannot get them to join our wifi network.

Thanks

Active Directory
Active Directory
A set of directory-based technologies included in Windows Server.
5,996 questions
0 comments No comments
{count} votes

3 answers

Sort by: Most helpful
  1. NonProfit 1 Reputation point
    2022-09-29T13:30:45.11+00:00

    Thanks for the links and I forgot to mention. We don't use SmartCards for logons. These are the first machines that I have seen that they have a type of smartcard and will not connect to our wifi. Joining the domain is fine and connected via Ethernet is fine but will not connect to Wifi, they continue to prompt for a username and password which should be pushed from GP.

    Thanks

    Luis

    0 comments No comments

  2. Dave Patrick 426.2K Reputation points MVP
    2022-09-29T14:09:54.4+00:00

    Dell support (or in their forums) will be your best resource for trouble shooting the hardware issues.

    --please don't forget to upvote and Accept as answer if the reply is helpful--

    0 comments No comments