.NET Framework 4.8 installation failed with catastrophic failure

Tan Eng Hong 1 Reputation point
2020-09-23T02:52:42.543+00:00

26596-cbs.txtI'm running Windows Server 2016 Datacenter with .NET Framework v4.6.01586. One of the software I'm trying to update requires minimum .NET Framework v4.7.2.

Initially I tried to update to .NET Framework v4.8 but it wasn't successful with error "one or more required members of the transaction are not present".

The same error was given when I tried installing .NET Framework v4.7.2 as well.

However, when I tried to install .NET Framework v4.7, I was shown the "0x8000ffff catastrophic failure" error. Subsequent attempts with v4.8 also showed "0x8000ffff catastrophic failure".

I've tried to use "Microsoft .NET Framework Repair Tool" but to no avail. Tried clean boot as well but still no go.

Installation log is as below:

OS Version = 10.0.14393, SP = 0.0, Platform 2
OS Description = Future OS - x64 Datacenter Edition
MSI = 5.0.14393.3503
Windows servicing = 10.0.14393.0
CommandLine = C:\22a428a81f907039f148ca\Setup.exe /x86 /x64 /redist
TimeZone = Central Daylight Time
Initial LCID = 1033
Using Simultaneous Download and Install mechanism
Package Name = Microsoft .NET Framework 4.8 Setup
Package Version = 4.8.03928
User Experience Data Collection Policy: Disabled
Number of applicable items: 6
Exe (C:\22a428a81f907039f148ca\SetupUtility.exe) succeeded.
Exe (C:\22a428a81f907039f148ca\SetupUtility.exe) succeeded.
Exe (C:\22a428a81f907039f148ca\x64-Windows10.0-KB4486129-x64.cab) failed with 0x8000ffff - Catastrophic failure .
Exe Log File: CBS.log
Final Result: Installation failed with error code: (0x8000FFFF), "Catastrophic failure " (Elapsed time: 0 00:00:36).

CBS file is as attached.

Windows Server 2016
Windows Server 2016
A Microsoft server operating system that supports enterprise-level management, data storage, applications, and communications.
1,760 questions
No comments
{count} votes

1 answer

Sort by: Most helpful
  1. Carl Fan 6,681 Reputation points Microsoft Employee
    2020-09-24T09:41:51.35+00:00

    Hi,
    As the CBS provided, WER: Generating failure report for package: Package_for_KB4486129~31bf3856ad364e35~amd64~~10.0.1.2919, status: 0x8000ffff, failure source: CBS Other.
    KB4486129 refers to .net framework 4.8.
    Did you install it with offline installation or using Windows Update?
    Temporarily turn off the security software.
    Open cmd windows, run as admin:
    DISM /Online /Cleanup-Image /RestoreHealth
    Meanwhile, I consider that you also should check the setup log in Event Viewer. To find if some errors were recorded.
    Next, you need to check the permission. Find the C:\Windows\ System32 \CatRoot2\ folder and give full control to the NETWORK SERVICE and SYSTEM and CryptSvc accounts. Try to install again.
    Hope this helps and please help to accept as Answer if the response is useful.
    Best Regards,
    Carl