I query Azure API and get error: getazuresubscriptionbyid returns null

Osmani Duenas 1 Reputation point
2022-10-03T18:17:17.453+00:00

247057-error.png

Azure Role-based access control
Azure Role-based access control
An Azure service that provides fine-grained access management for Azure resources, enabling you to grant users only the rights they need to perform their jobs.
686 questions
Microsoft Entra ID
Microsoft Entra ID
A Microsoft Entra identity service that provides identity management and access control capabilities. Replaces Azure Active Directory.
19,852 questions
{count} votes

1 answer

Sort by: Most helpful
  1. Marilee Turscak-MSFT 34,786 Reputation points Microsoft Employee
    2022-10-04T20:39:15.253+00:00

    Hi @Osmani Duenas ,

    Thanks for your post! If you are seeing the subscription "not found" error, the most common causes for this issue are if the wrong directory is being selected, if the directory does not have the subscription linked to it, or if the account has insufficient permissions. You mention that you already have subscription Owner permissions, so if that is the case, I would ensure that the correct tenant is selected and the tenant has that subscription properly linked to it.

    One way to resolve this issue if you have already verified the above is to create a brand new user, add the subscription Owner role to that user, and try again.

    If those steps do not work, I would recommend creating a ticket with the billing/subscription team, since
    billing/subscription support is free. I've seen a few cases where accounts were locked due to incorrect payment information and other reasons.

    Also, I'm not familiar with the UI in your screenshot, but it looks like something from the ControlUp Real-Time Console. This is a third party tool and I don't believe that it is officially supported from our end. For this reason, I would recommend reaching out to the ControlUp support team for this issue and reviewing their integration guide to see if there is something missing in the connection to Azure. Based on their support page there does appear to be some latency when refreshing the data in the console.

    247546-image.png

    -

    If the information helped you, please Accept the answer. This will help us and other community members as well.

    0 comments No comments