Can't run Visual Studio 2022 at all

Richard Bethell 1 Reputation point
2022-10-03T20:11:19.213+00:00

On Win10, it opens without any templates, any attempt to load any project flashes "Cannot load file or assembly netstandard, version 2.1.0.0", can't even exit Visual Studio without taskkill (that same error message), and the ActivityLog.xml also gripes about missing netstandard.

No amount of reinstalling/removing/repairing makes any difference.

How do I get a recognized copy of netstandard.dll in place, and where would I put it?

UPDATE: even installing build tools for Visual Studio 2022 is a washout... same error on the commandline.

Visual Studio
Visual Studio
A family of Microsoft suites of integrated development tools for building applications for Windows, the web and mobile devices.
4,698 questions
0 comments No comments
{count} votes

1 answer

Sort by: Most helpful
  1. Tianyu Sun-MSFT 27,811 Reputation points Microsoft Vendor
    2022-10-04T07:02:13.253+00:00

    Hi @Richard Bethell ,

    Welcome to Microsoft Q&A forum.

    Please try following suggestions:

    1. Update Windows 10, and if there’s any error about updating Windows 10 or installing Update components, please try to fix it first.
    2. Try this SFC tool to repair missing or corrupted system files.
    3. If you have any antivirus software installed, please try to stop it temporarily.
    4. Please make sure that you have full permissions on your machine.
    5. Try to install .NET 6.0.

    Best Regards,
    Tianyu

    • If the answer is the right solution, please click "Accept Answer" and kindly upvote it. If you have extra questions about this answer, please click "Comment".
      Note: Please follow the steps in our documentation to enable e-mail notifications if you want to receive the related email notification for this thread.