Azure API Manager OpenApiSpecification parser error for valid json

Jaime Huffman 56 Reputation points Microsoft Employee
2022-10-03T23:37:53.023+00:00

We had a similar issue last October. This time there is a single error: "Unable to parse backend url from servers: '/'"

We have pasted the json into https://editor.swagger.io/ and it works. We also tried a different json that uploaded fine over the summer and it gives the same error. Is there something going wrong on the Azure side again?

247185-microsoftteams-image-6.png

Azure API Management
Azure API Management
An Azure service that provides a hybrid, multi-cloud management platform for APIs.
1,805 questions
{count} votes

Accepted answer
  1. MuthuKumaranMurugaachari-MSFT 22,236 Reputation points
    2022-10-13T01:57:48.81+00:00

    @Jaime Huffman Thank you for reaching out to Microsoft Q&A. Sorry for the inconvenience caused by this issue. If you are importing OpenApi 3.0 schema without Servers and facing this issue in the azure portal, then this is a known issue. Per OpenApi 3.0, if servers array is not provided in the schema it defaults to '/' which causes the failure in the portal. Our product team is working on the fix and ETA is around 2-3 months subject to change based on other factors.

    Workaround is to use PowerShell, CLI or REST to import API or add a valid URL such as "https://www.bing.com" to the Servers array.

    If you face any issues with the workaround, please let us know to investigate further. I hope this answers your question and feel free to add a comment if you have any other questions. We would be happy to assist you. Please 'Accept as answer' and ‘Upvote’ if it helped so that it can help others in the community.


0 additional answers

Sort by: Most helpful