How to enable TLS 1.1 for Microsoft Edge on Windows 11

Anh Kiệt Nguyễn 1 Reputation point

I want to enable TLS 1.1 for edge on windows 11. But I can't find where to do that, I tried going to edge://flags, I also tried enabling in penalty control -> internet options. But it has no work.

Microsoft Edge
Microsoft Edge
A Microsoft cross-platform web browser that provides privacy, learning, and accessibility tools.
2,166 questions
{count} votes

3 answers

Sort by: Most helpful
  1. Dillon Silzer 54,746 Reputation points

    Hi @Anh Kiệt Nguyễn

    Please take a look at a similar question at (answered by Yu Zhou-MSFT)

    As the doc describes, TLS 1.0/1.1 will remain disabled by default in Microsoft Edge version 84 and later. If you want to enable them manually, you can refer to the following steps:

    Open Edge and navigate to edge://flags/.
    Type TLS in the search bar.
    Change the value of Enforce deprecation of legacy TLS versions to Disabled.
    Restart Edge.

    After finishing the above steps, when you visit again in Edge, it will show TLS 1.0 and TLS 1.1 enabled.

    Please recheck edge://flags for the settings above.


    If this is helpful please accept answer.

  2. Noel Burgess 626 Reputation points

    Right-click on Start and select Run. Type inetcpl.cpl into the run box and press Enter. On the Advanced tab of the Internet Properties dialogue, enable TLS 1.1 under Security.

  3. ShiJieLi-MSFT 8,026 Reputation points Microsoft Vendor

    Hi @Anh Kiệt Nguyễn ,

    I'm afraid for the latest version of Microsoft Edge, enabling TLS 1.1 is not an option. The modification in Internet Options is used for IE and EdgeHTML. Here're 2 docs for you to refer to:

    If the answer is helpful, please click "Accept Answer" and kindly upvote it. If you have extra questions about this answer, please click "Comment".

    Note: Please follow the steps in our documentation to enable e-mail notifications if you want to receive the related email notification for this thread.

    Best Regards,
    Shijie Li