Powershell Timeout

Miguel Flores 1 Reputation point
2022-10-07T10:50:56.687+00:00

I am running Step 5 of https://github.com/MicrosoftLearning/DP-500-Azure-Data-Analyst and PowerShell timesout after 20 minutes.

This is what I see in the PowerShell screen:

Starting script at 10/07/2022 10:31:17
WARNING: The version '1.6.0' of module 'Az.Synapse' is currently in use. Retry the operation after closing the applications.

Enter a password to use for the SQLUser login.
The password must meet complexity requirements:
- Minimum 8 characters.
- At least one upper case English letter [A-Z]
- At least one lower case English letter [a-z]
- At least one digit [0-9]
- At least one special character (!,@,#,%,^,&,$)
: xxxxxxxxxx
Password 1berenGena3! accepted. Make sure you remember this!
Registering resource providers...

Windows Server PowerShell
Windows Server PowerShell
Windows Server: A family of Microsoft server operating systems that support enterprise-level management, data storage, applications, and communications.PowerShell: A family of Microsoft task automation and configuration management frameworks consisting of a command-line shell and associated scripting language.
5,396 questions
0 comments No comments
{count} votes

1 answer

Sort by: Most helpful
  1. Ian Xue (Shanghai Wicresoft Co., Ltd.) 31,016 Reputation points Microsoft Vendor
    2022-10-10T03:36:15.497+00:00

    Hi,

    Did you run the script from https://github.com/MicrosoftLearning/DP-500-Azure-Data-Analyst/blob/main/Allfiles/04/setup.ps1? If so, you can run the Register-AzResourceProvider cmdlet in line 40 manually and also see if the providers can be registered through the azure portal. You may add the azure tags since this seems more an azure issue to me.

    Best Regards,
    Ian Xue

    -----------------------------

    If the Answer is helpful, please click "Accept Answer" and upvote it.
    Note: Please follow the steps in our documentation to enable e-mail notifications if you want to receive the related email notification for this thread.

    0 comments No comments