VMWare Workstation Pro 15.0 rolling back setup on Windows 7

sidrasaeen18 1 Reputation point
2022-10-12T11:01:45.367+00:00

I'm trying to install VMWare Workstation Pro 15.0. 32 bit version on my 64-bit Windows 7 Ultimate Service Pack 1 machine but it always rolls back setup.

I tried rebooting, deleting vmkbd3 key from the registry, but always the same.

It even places icon on the desktop and than prompts a window with exclamation mark and button OK. When clicked it rolls back the installation process and says that setup has ended up prematurely. It's just so frustrating. I tried from cmd to repair installation file but interestingly I can't. It doesn't even want to repair the damn setup file. Finally, I tried removing cache it created in program files in Common files folder but again the same damn thing happens.

Why the same 32-bit version wants to install and work on my 64-bit Windows 10 Professional from which I'm posting this thread right now, but fiercely refuses to install and work on 64-bit Windows 7 Ultimate machine?

I even installed update KB3033929 which some people claimed that solves the issue. And the same thing happens all over again.

Does anybody have a clue how to get it up and running because I've read so many threads about the same issue and just nothing works for me.

Windows
Windows
A family of Microsoft operating systems that run across personal computers, tablets, laptops, phones, internet of things devices, self-contained mixed reality headsets, large collaboration screens, and other devices.
4,872 questions
0 comments No comments
{count} votes

1 answer

Sort by: Most helpful
  1. Dave Patrick 426.2K Reputation points MVP
    2022-10-12T12:55:05.02+00:00

    Might try them over here in dedicated forums.
    https://communities.vmware.com/t5/VMware-Workstation/ct-p/3019-home

    --please don't forget to upvote and Accept as answer if the reply is helpful--

    0 comments No comments