RDP Stopped working for HyperV Machine

Clay Skinner 1 Reputation point
2022-10-14T19:46:03.513+00:00

We have two physical Windows 11 hosts in a datacenter, with a Windows 11 VM running in Hyper-v on one of those hosts. Up until today, we were able to remote into all 3 machines using RDP but now we are unable to get to the Hyper V machine with RDP. All machines are part of the same group in Azure, and we use Intune to push out config profiles based on Microsoft's security recommendations to this group. The only changes that have been recently made to configuration profiles are the following (these all are from Secure Score recommendations):

  • Enable 'Network Protection'
  • Disable merging of local Microsoft Defender Firewall connection rules with group policy firewall rules for the Public profile
  • Disable merging of local Microsoft Defender Firewall rules with group policy firewall rules for the Public profile

Although we have enabled these, the two host machines have not been affected, we can still remote in fine, but for the Hyper-V machine we cannot. I can still connect to the VM through Hyper-V manager on the host machine and confirmed in system properties that RDP is allowed and set to only network level auth. But under Remote Desktop settings, I cannot adjust the slider to allow Remote desktop:

250610-image.png

Any suggestions or help on this topic would be appreciated.

Remote Desktop
Remote Desktop
A Microsoft app that connects remotely to computers and to virtual apps and desktops.
4,283 questions
Windows 11
Windows 11
A Microsoft operating system designed for productivity, creativity, and ease of use.
8,371 questions
0 comments No comments
{count} votes

4 answers

Sort by: Most helpful
  1. Dave Patrick 426.2K Reputation points MVP
    2022-10-14T19:49:49.827+00:00

    Might try from PowerShell from both source and target (use the target address in both tests).

    Test-NetConnection -ComputerName "192.168.49.142" -CommonTCPPort "RDP" -InformationLevel "Detailed"  
    

  2. Dave Patrick 426.2K Reputation points MVP
    2022-10-14T20:00:15.407+00:00

    This tells use there either is no route or that the port is blocked. If "ping" in the test above succeeded then its the port that's blocked.

    --please don't forget to upvote and Accept as answer if the reply is helpful--


  3. Dave Patrick 426.2K Reputation points MVP
    2022-10-14T21:00:36.51+00:00

    Has it ever worked? May need to check if a policy is pushing something. rsop.msc may provide something.

    --please don't forget to upvote and Accept as answer if the reply is helpful--


  4. Dave Patrick 426.2K Reputation points MVP
    2022-10-14T21:32:40.22+00:00

    I'd stand up a new one for testing. Confirm it works before domain join, then join and test it again. Another thought / option is if you can start the Remote Desktop Services(TermService) service, then manually create the firewall rules here then I believe it should work.

    --please don't forget to upvote and Accept as answer if the reply is helpful--

    250675-image.png