Windows Server 2016 will not allow installation of sata drives in storage pool

Thomas Park 41 Reputation points
2022-10-15T17:03:49.643+00:00

I started out with Windows Home Server. It worked great until it was discontinued. Eventually I migrated to WSE 2012R. It worked fine but keeping in mind my WHS experience I decided to upgrade. I eventually chose WSE 2016 since 2019 did not allow for remote desktops. The initial install to WSE 2012 from WHS went flawlessly. When I did the upgrade to 2016 the system crashed. I have no idea why. It took some time but I found my data, reconfigured it, replaced the expansion card, replaced the Mobo, and now I am adjusting my storage pools. I have added 2 x 4TB sata drive and an 8tb sata drive. The mobo and the OS both see the drives just fine. I configured the Adaptec 7805 raid HBA card to be a HBA passthrough for my drives. Disk management had no problem with the drives. My client PC's using a remote desktop sees the drives properly. It is just that every time I try to add them to a storage pool I get an error message. At first I thought it was the 8tb causing problems but when it is not included in the pool it makes no difference. The 2 x 4tb drives are errored as well. I read somewhere that raid bus drives cannot be added to a storage pool. I can't seem to get rid of the raid bus designation. I did a lot of research before I bought the adaptec card and it should work. Do I have to delete the drives from the Server operating system? Then let the OS find them, hopefully on the sas / HBA bus? What do I do now? I look forward to your help.

Mobo is Asus Server model P5BV-E/SAS with 8 GB of onboard Ram (old but works great otherwise) It has a Xeon x3360 2.85 gigahertz processor
Originally in the 2012 build it had a cheap sata expansion card in a similar board but I believe the system crashed when the add-on board blew a rail. My new power supply is the best available, no issues there.
System works great but I can't seem to increase the storage pool.

Windows Server
Windows Server
A family of Microsoft server operating systems that support enterprise-level management, data storage, applications, and communications.
12,330 questions
0 comments No comments
{count} votes

Accepted answer
  1. Dave Patrick 426.2K Reputation points MVP
    2022-10-15T19:22:11.973+00:00

    As I said the problem lies in WSE 2016

    Understood, and Server 2016 looks to be not supported. Might try installing a supported operating system to test with.
    https://www.windowsservercatalog.com/item.aspx?idItem=101F1455-B2CB-6906-B0AE-D7429B7E1A0B&bCatID=1282

    --please don't forget to upvote and Accept as answer if the reply is helpful--

    0 comments No comments

3 additional answers

Sort by: Most helpful
  1. Dave Patrick 426.2K Reputation points MVP
    2022-10-15T18:34:05.223+00:00

    The age of the hardware seems to be problematic for Server 2016. While this doesn't mean it can't or won't work it does mean the process of vetting components is left to the end user to sort out.

    --please don't forget to upvote and Accept as answer if the reply is helpful--

    250806-image.png

    0 comments No comments

  2. Thomas Park 41 Reputation points
    2022-10-15T19:18:48.2+00:00

    I did cheque out the drive due to the age of the Mobo. Asus Saud the card is compatible. As I said the problem lies in WSE 2016. the drives are seen by the OS. I am looking to see if there is something along the lines of deleting the drives from windows, turning off the system rebooting and letting the OS find the drives after the system reboots. I also read in another forum that registry changes can affect bus recognition. I can assure you I did check hardware compatibility. Sadly after I bought a Supermicro card was useless to me as it only works with their motherboard. Lesson learned. Sadly. I truly believe the issue lies in the OS configuring drives and artifacts having left on the system after initially loading the card in raid setting. Now corrected but I can't seem to get rid of raid bus designation. As stand alone drives they all work great. I just lose the redundancy that comes with storage pools. At worst I can use them as drives without back ups.

    0 comments No comments

  3. Thomas Park 41 Reputation points
    2022-10-15T21:07:37.297+00:00

    Deleted the drives in question from disk manager and device manager. Rebooted system. OS allowed me to integrate the drives into the storage pool. No further problems with OS. WSE 2016 works well. All is good. Thanks for your efforts.