Azure Migration appliance - Failed to register the appliance

Karl Wester-Ebbinghaus 36 Reputation points MVP
2022-10-15T21:34:43.507+00:00

I have now setup 2 appliances one script based (AzureMigrateInstaller.ps1), another time as Hyper-V  template download and both terminate the workflow at after the successful login.

Azure user login and appliance registration status
You need to Login to your Azure account to proceed. Ensure you have the required permissions on the Azure account.​
Logged in as joe@Company portal .com

Error Message

Failed to register the appliance. Check the error details, follow the remediation steps and click on 'Retry' button

Failed to save configuration
Details
The check failed as the URL https://myservice7238kv.vault.azure.net is not reachable and has returned an error: 'An error occurred while sending the request.'. This can happen if you have not whitelisted the required URLs for connectivity to Azure or have not provided the correct proxy details in the configuration manager to access the URLs.

In the docs there is no description I would need to manually create a vault. The diagnosis of the web portal does not indicate any connection issue and until this step all connections and the workflows are running fine.

Azure Migrate
Azure Migrate
A central hub of Azure cloud migration services and tools to discover, assess, and migrate workloads to the cloud.
728 questions
0 comments No comments
{count} votes

3 answers

Sort by: Most helpful
  1. Karl Wester-Ebbinghaus 36 Reputation points MVP
    2022-10-15T22:39:53.297+00:00

    Found the solution. The Azure Migration Appliance does not create the Azure Key vault as described in the error message.

    Created an own Azure Key Vault (make sure on the networking tab the networking fits to your configuration intend of the Azure Migration VM (public or private)

    learn.microsoft.com do not specify a manual creation of the Key Vault either: source: https://learn.microsoft.com/en-us/azure/migrate/tutorial-discover-hyper-v

    after creating the Key Vault, you should allow Azure the replicate changes internally for about 5-15 minutes aka "the Azure minute" before you choose to retry on the appliance.

    0 comments No comments

  2. tbgangav-MSFT 10,391 Reputation points
    2022-10-17T09:14:15.06+00:00

    Hi @Karl Wester-Ebbinghaus ,

    Glad to know that you have self-resolved and thanks for sharing it. This will definitely help other community members who might be looking for similar issue. Thanks.

    0 comments No comments

  3. Gianni Lattanzio 0 Reputation points
    2024-03-14T11:07:56.6666667+00:00

    Hello,

    I've an issue with Azure Migrate Appliance. The "Set up prerequisites" it's ok, my problem it's when I add discovery Source. I add my Hyper-V Host with mapped credentials and I've an error : "The given key was not present in dictionary". I run a diagnostic I've nothing wrong.

    Someone have an idea ?

    Thanks

    0 comments No comments