How to Enable PDFSecure Mode in Edge ?

Pravin Harsure 1 Reputation point
2022-10-18T06:24:55.773+00:00

We are trying to Enable this PDFSecure Mode in Edge Browser so that we can validate / open Digitally Signed PDF Documents in Edge Browser.

As per MS Edge Policy Document we found this https://learn.microsoft.com/en-us/deployedge/microsoft-edge-policies#pdfsecuremode

We created this Registry Entry PDFSecureMode with Value 1 as per the Document but its not working

Windows Registry Settings
Path (Mandatory): SOFTWARE\Policies\Microsoft\Edge
Path (Recommended): N/A
Value Name: PDFSecureMode
Value Type: REG_DWORD
Value: 0x00000001

Can anyone help us to achieve this ? any document or any suggestion ? am i missing something here ? Please help

Microsoft Edge
Microsoft Edge
A Microsoft cross-platform web browser that provides privacy, learning, and accessibility tools.
2,205 questions
{count} votes

2 answers

Sort by: Most helpful
  1. Pravin Harsure 1 Reputation point
    2022-10-19T06:17:06.953+00:00

    Hi @Yu Zhou-MSFT

    Edge Version :- 106 (Latest Release) OS :- Windows 10 21H2

    I have two machines one is my Company and another is Personal (In Company Machine Browser is Managed by Organisation via GPO)

    When i Enable this Policy on my Personal Machine by Creating Registry its working as expected you can see that in snaps attached below.

    251807-image.png
    251834-image.png
    251779-image.png

    But when i tried to perform this my my Company Laptop this is not working the option to Validate Digital signature is not there.

    just wanted to know is there anything blocking to enable this any Policy or something like that ?

    0 comments No comments

  2. Yu Zhou-MSFT 12,541 Reputation points Microsoft Vendor
    2022-10-19T10:08:12.197+00:00

    Hi @Pravin Harsure

    As you say your company computer is managed by organization via GPO, there might be some GPOs set by your organization which conflict with the GPO you set by yourself locally. GPOs set in different level have different privileges. I think that's why it doesn't work in your company computer. AFAIK, there's no other reasons which will blocking the policy.

    If you want to set PDFSecureMode policy, I suggest that you can consult your IE department and ask them to configure the policy in organization. Thanks for your understading.


    If the answer is the right solution, please click "Accept Answer" and kindly upvote it. If you have extra questions about this answer, please click "Comment".
    Note: Please follow the steps in our documentation to enable e-mail notifications if you want to receive the related email notification for this thread.

    Regards,
    Yu Zhou

    0 comments No comments