App Service is offline

research 1 Reputation point
2022-10-18T15:40:09.197+00:00

When trying to deploy the app from Visual Studio. It is giving the following error

Web deployment task failed. (Could not connect to the remote computer ("suppliersearchsystem.scm.azurewebsites.net") using the specified process ("Web Management Service") because the server did not respond. Make sure that the process ("Web Management Service") is started on the remote computer. Learn more at: https://go.microsoft.com/fwlink/?LinkId=221672#ERROR_COULD_NOT_CONNECT_TO_REMOTESVC.)

But, in the azure portal status of app service is "running". Unable to find the issue.

When i was hitting website. It was showing "App Service Offline". but after deleting app_offline.htm under wwwroot through console in the portal, previous deployed version of the app is running.

But can't deploy new changes from Visual studio

Any help would be appreciated.

Azure App Configuration
Azure App Configuration
An Azure service that provides hosted, universal storage for Azure app configurations.
210 questions
Azure Policy
Azure Policy
An Azure service that is used to implement corporate governance and standards at scale for Azure resources.
816 questions
Azure App Service
Azure App Service
Azure App Service is a service used to create and deploy scalable, mission-critical web apps.
7,157 questions
0 comments No comments
{count} votes

2 answers

Sort by: Most helpful
  1. Sam Cogan 10,327 Reputation points MVP
    2022-10-18T15:43:07.813+00:00

    Sounds like you may have applied network restrictions to the app service. If you do that and hit it from an address that is not allowed you will see the app offline error.

    0 comments No comments

  2. SnehaAgrawal-MSFT 19,436 Reputation points
    2022-10-27T06:28:43.2+00:00

    @research Just checking here if you chance to see response of Sam-Cogan, as suggestions on error is to ensure,

    • You can ping the remote machine
    • That the msdepsvc or wmsvc service is started on the remote server.
    • Your firewall is not blocking incoming connections of your ports on the destination. If you used the default installation, then it would be 80 for msdepsvc and 8172 for wmsvc.

    Please let us know if further query or issue remains.

    0 comments No comments