Error - Exercise - Create a SQL database

Simone F N Tassi 21 Reputation points

Hi everybody,

During the Exercise 'Learn Training Browse Explore Azure database and analytics services ' I got the following error 'Template violation', does anybody know how to fix it?


Azure SQL Database
{count} votes

Accepted answer
  1. Jonathan Roundy 81 Reputation points

    I just walked through the process after finding the Exercise referenced in the Title of this post. I have placed the link below.

    I think there may have been an error in the provided template, unless maybe you made adjustments to the template before attempting to deploy it. I did not need to set the parameter specified in your error message

    I was able to successfully deploy the db1 SQL Database in my case. I also noticed there is a feedback link after the deployment completes, I'm not sure if it is there when it is validating the template though. This might get your question or issue resolved more quickly.

    @Suba Balaji

    Link to Exercise: exercise-create-sql-database

    0 comments No comments

2 additional answers

Sort by: Most helpful
  1. Oury Ba-MSFT 14,061 Reputation points Microsoft Employee

    @Jonathan Roundy Thank you for your contribution. @Simone F N Tassi Please confirm if you have followed the link provided by @Jonathan Roundy above. If yes, please check if you have made any changes on the template before deployment. I have also tried to repo the issue from my end, and I was able to successfully create db1 on Azure.

    Please let us know


    0 comments No comments

  2. Simone F N Tassi 21 Reputation points

    Thank you. I tried to execute the exercise today and it worked. I did not change anything before (even because I had not the option to change it) and the same today, just followed the same steps but now it is working. ^_^