ExchangeOnlineManagement v3 fails to connect in ISE

Matthew Hale 21 Reputation points

I recently update the ExchangeOnlineManagement module to version 3.0.0 via Update-Module. Now it fails to connect, but only in the ISE environment for some reason.

PS C:\> Connect-ExchangeOnline  
You cannot call a method on a null-valued expression.  
At C:\Program Files\WindowsPowerShell\Modules\ExchangeOnlineManagement\3.0.0\netFramework\ExchangeOnlineMa  
nagement.psm1:691 char:17  
+ ...             $cmdletLogger.LogGenericError($connectionContextID, $glob ...  
+                 ~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~  
    + CategoryInfo          : InvalidOperation: (:) [], RuntimeException  
    + FullyQualifiedErrorId : InvokeMethodOnNull  

The error mentions the logger is failing, so I also tried different values for -LogLevel and -LogDirectoryPath, and I tried this on a few different machines (win10,server2012/16) without any luck.

I know VS Code is prioritized, but ISE is still supported and it's what I have available. It's not critical for me to update, but wanted to check that it's not just something in my environment

Microsoft Exchange Online Management
Microsoft Exchange Online Management
Microsoft Exchange Online: A Microsoft email and calendaring hosted service.Management: The act or process of organizing, handling, directing or controlling something.
3,865 questions
Windows Server PowerShell
Windows Server PowerShell
Windows Server: A family of Microsoft server operating systems that support enterprise-level management, data storage, applications, and communications.PowerShell: A family of Microsoft task automation and configuration management frameworks consisting of a command-line shell and associated scripting language.
5,170 questions
0 comments No comments
{count} votes

1 additional answer

Sort by: Most helpful
  1. Matthew Hale 21 Reputation points

    Yep, that was the cause, and thanks for the reply! I figured it was something with my environments...

    I had version 2.0.4, 2.0.5, and 3.0.0 installed on the systems I tested

    0 comments No comments