Azure Pipeline is failing in "Xcode@5" task with error

Charmi PATALIA 1 Reputation point
2022-10-31T03:48:04.567+00:00

I am using Azure pipelines to upload my iOS apps to TestFlight. It was working fine before but recently I changed the vmImage to "macOS-12" in .yml file with xCode 14.0.1 and after that pipeline is failing in "Xcode@5" task with error code 65.

In .yml file, in Xcode@5 task for "signingOption", I tried "auto" and"manual" both but issue is same in both cases. If I use "default" than it is failing with error code 70.

I also updated my certificates and profiles recently so it seems no error related to that and also build is successfully uploaded by Xcode but it is giving error in pipeline.

I am attaching the error logs for both the cases.

255505-errorcode65.txt
255506-errorcode70.txt

Here is task description in .yml file

  • task: Xcode@5
    displayName: Build and Sign
    inputs:
    workingDirectory: '$(workingDirectory)'
    xcWorkspacePath: '$(workingDirectory)/EvolutionWellness.xcworkspace'
    actions: 'build'
    sdk: 'iphoneos16.0'
    scheme: '$(scheme)'
    configuration: 'Release PROD'
    packageApp: true
    exportPath: '$(system.defaultworkingdirectory)'
    signingOption: 'manual'
    signingIdentity: '$(APPLE_CERTIFICATE_SIGNING_IDENTITY)'
    provisioningProfileUuid: '$(APPLE_PROV_PROFILE_UUID)'
    teamId: 'G7GD45FUCY'
    args: '-verbose'
Not Monitored
Not Monitored
Tag not monitored by Microsoft.
37,130 questions
{count} votes

2 answers

Sort by: Most helpful
  1. tbgangav-MSFT 10,411 Reputation points
    2022-10-31T15:07:11.893+00:00

    Hi @Charmi PATALIA ,

    Azure DevOps is currently not supported in this Microsoft Q&A platform. These are the products that are currently supported in this Microsoft Q&A platform. You may ask Azure DevOps related questions in this developer community / via this Azure DevOps services support.

    0 comments No comments

  2. Charmi PATALIA 1 Reputation point
    2022-12-07T12:29:03.653+00:00

    Hello @Shaikh, Nikhat Parvez Alam , yes I am able to solve the issue now. Please check my latest answer here.

    https://github.com/microsoft/azure-pipelines-tasks/issues/17114#issuecomment-1340877896