AVD audio redirection not working

Kyle Sims 1 Reputation point
2022-10-31T17:07:39.437+00:00

Hello!

We have a new client using an AVD. The AVD is running Windows 11. When logging into the AVD using the AVD desktop client downloaded from Microsoft, audio resources are not being redirected.

What we want/expect when logged into the AVD:
for audio to be played through our headphones/speakers
Our USB/built in cameras to redirect to the AVD
Our USB/built in mic's to redirect to the AVD

What's happening when logged into the AVD:
Camera is redirecting fine
Mics and audio are not redirecting. The AVD shows no sound devices at all.

Here's a screenshot of the host pool RDP properties -

255782-image.png

And the text string version of the same thing,

drivestoredirect:s:;audiomode:i:0;videoplaybackmode:i:1;redirectclipboard:i:1;redirectprinters:i:1;devicestoredirect:s:;redirectcomports:i:1;redirectsmartcards:i:1;usbdevicestoredirect:s:;enablecredsspsupport:i:1;redirectwebauthn:i:1;use multimon:i:1;autoreconnection enabled:i:1;audiocapturemode:i:1;camerastoredirect:s:;redirectlocation:i:1;singlemoninwindowedmode:i:1;smart sizing:i:1;dynamic resolution:i:1

Azure Virtual Desktop
Azure Virtual Desktop
A Microsoft desktop and app virtualization service that runs on Azure. Previously known as Windows Virtual Desktop.
1,409 questions
{count} votes

1 answer

Sort by: Most helpful
  1. moonshdw8 1 Reputation point
    2023-06-16T19:32:01.45+00:00

    Anyone else having this issue and the above suggestions don't work, this is what worked for me.

    Under the Azure Host Pool > RDP Properties > Advanced Tab, it had listed audiomode:i:0 setting before the audiocapturemode:i:1.

    Once I manually swapped the order (cut and paste) and put audiocapturemode:i:1 before audiomode:i:0 and saved it, everything worked as expected.

    0 comments No comments