Can no longer connect from MySQL Workbench

beka89 1 Reputation point
2022-11-03T00:20:44.307+00:00

I have an Azure student account, and I had set up a MySQL database a couple of months ago. There were zero issues, until it suddenly stopped being able to connect-- now I get the error message 256583-mysql-error-11022022.png
Nothing changed-- I had not edited the connection, or changed anything about my network settings. I even tried making a new connection with the same credentials, and got the same error. There's no firewall, so that should not be an issue, and I'm stumped, especially since the connection had been working up until that point.

Azure Database for MySQL
Azure Database for MySQL
An Azure managed MySQL database service for app development and deployment.
747 questions
0 comments No comments
{count} votes

1 answer

Sort by: Most helpful
  1. GeethaThatipatri-MSFT 28,617 Reputation points Microsoft Employee
    2022-11-03T02:17:54.417+00:00

    Hi,@beka89 Welcome to the Microsoft Q&A forum, Thanks for posting your question.
    As I understand correctly you are facing a connection issue while connecting from the Mysql workbench.
    Check in the Azure portal and make sure you are able to see the server available and also make sure you are able to list the database ... if you are able to view both then the issue is with your network or firewall.

    Please let me know if this helps.
    Regards
    Geetha