the current compatibility setting is not supported. disable compatibility view before running the web page

Sethujaganathan S 1 Reputation point
2022-11-07T01:08:22.783+00:00

Facing issues with loading application with Microsoft edge. It was built with Oracle ADF and was working with Web logic server(WLS) 12.1.3.0 and getting compatibility popup and unable to provide way to use the web app using edge after upgrading it to Oracle WLS 12.2.1.4; Could you please help me resolve the issue, it is blocking the users working with the build application, which is working ok in Chrome browser but some of the features and functionalities are best worked in IE before now in Edge.

Tried the options of changing compatibility using debfault browser settings in edge or using the enterprise mode site list manager, nothing works out for me.

Microsoft Edge
Microsoft Edge
A Microsoft cross-platform web browser that provides privacy, learning, and accessibility tools.
2,204 questions
Windows 10 Compatibility
Windows 10 Compatibility
Windows 10: A Microsoft operating system that runs on personal computers and tablets.Compatibility: The extent to which hardware or software adheres to an accepted standard.
460 questions
{count} votes

2 answers

Sort by: Most helpful
  1. Yu Zhou-MSFT 12,541 Reputation points Microsoft Vendor
    2022-11-08T06:28:33.24+00:00

    Hi @Sethujaganathan S

    From your screenshot, the site is running with IE7 compatibility mode. If you want to change it to IE11 compatibility mode, you need to edit the Enterprise mode site list file. Please follow the steps below to see if you can fix the issue:

    1. Navigate to edge://compat/enterprise in Edge. The value after Location is the path of your Enterprise mode site list file. 258068-image.png
    2. Open the Enterprise mode site list file according to the location and change the corresponding site setting like below to make it use IE11 compatibility mode. If you're not sure how to edit the file, you can provide the screenshot of the file and I can suggest how to edit. You can also refer to Enterprise Mode v.2 schema example for more information. <site url="yoursite.com">
      <compat-mode>IE11</compat-mode>
      <open-in allow-redirect="true">IE11</open-in>
      </site>
    3. After editing and saving the Enterprise mode site list file, click Force update on page edge://compat/enterprise.
    4. Reopen the site in Edge and click the IE icon of that page to see if it loads in IE11 compatibility mode.

    If the answer is the right solution, please click "Accept Answer" and kindly upvote it. If you have extra questions about this answer, please click "Comment".
    Note: Please follow the steps in our documentation to enable e-mail notifications if you want to receive the related email notification for this thread.

    Regards,
    Yu Zhou


  2. Sethujaganathan S 1 Reputation point
    2022-11-09T22:00:03.553+00:00

    Thanks for your inputs, much appreciated to driving me towards a logical conclusion on the issue!

    We just removed the IE compatibility settings for the specific URL(in edge://compat/enterprise) and tested it. It is now, not poping up with the compatibility message and application now is working ok. Will keep you posted with further updates or if require any further assistance.